16

I went to edit this question and noticed this...

enter image description here

Bearing in mind this was pre-edit - how did the question successfully post in the first place?

To clarify, revision 2 of this post has this:

enter image description here

Revision #3 is when I then edited that out...

So I guess the question is, how did revision 2 successfully submit ?

7

I've adjusted our test to disallow any type of space between "help" and "with", on Stack Overflow.

  • Thanks! While you're at it, can you do the same for "[on hold]" too? – Ilmari Karonen Feb 18 '14 at 14:08
  • 1
    @IlmariKaronen - looking into that. It is a completely different check done in a completely different place, in a completely different way ;) – Oded Feb 18 '14 at 14:31
5

UPDATED ANSWER

it is easy:

I Need help#with....

Replace the hash with Alt+255. which is a space, but not a space. So for the filter it is one word " help#with ". So it passes the filter, try it out. I have made an edit for the same question in SO, if someone can accept it so it will show, my rep there is not enough to edit it myself.

List of Unicode letters that can fool the filter:

U+00A0
U+202F
U+FEFF

There could be more..

  • 2
    No. @JonClements got that error while editing. Go to the question and try to edit that keyword. – hims056 Feb 14 '14 at 12:28
  • @hims056 updated the answer. – Nean Der Thal Feb 14 '14 at 12:35
  • 1
    The filter does take zero-width and other non-standard spaces into account, actually. And the output doesn't contain that character either. – Martijn Pieters Feb 14 '14 at 12:43
  • @MartijnPieters I have tried it and it worked :) should I post a question in SO just to prove that? – Nean Der Thal Feb 14 '14 at 12:44
  • @MeNoTalk: Sure, it could easily be that I missed one. I don't use Windows; do you know what Unicode codepoint Alt+255 produces? – Martijn Pieters Feb 14 '14 at 12:45
  • Ah, found it, U+00A0, confirmed that. – Martijn Pieters Feb 14 '14 at 12:47
  • That may well work, but it doesn't seem to be how the OP did it; the title doesn't have any non-ASCII code points. – Ilmari Karonen Feb 14 '14 at 12:47
  • it is U+00A0 I guess – Nean Der Thal Feb 14 '14 at 12:47
  • @IlmariKaronen: I tried it, the non-breaking space is filtered out. – Martijn Pieters Feb 14 '14 at 12:50
  • @IlmariKaronen: see stackoverflow.com/revisions/21778373/12; that revision uses the U+00A0 character. – Martijn Pieters Feb 14 '14 at 12:51
  • FWIW: Please see this answer. – hims056 Feb 14 '14 at 12:55
  • @MartijnPieters: OK, that's just weird. I just downloaded the page and looked at it in a hex editor, and all the spaces are normal ones! It's as if the back-end is normalizing them, but only after the word blacklist check. – Ilmari Karonen Feb 14 '14 at 12:55
  • @IlmariKaronen: exactly. – Martijn Pieters Feb 14 '14 at 12:56
  • 1
    They are being normalized after they pass the filter... – Nean Der Thal Feb 14 '14 at 12:56
  • 2
    @IlmariKaronen: this very question can be that bug report. – Martijn Pieters Feb 14 '14 at 13:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .