1

As the title says, there seems to be a strange bug in the StackOverflow Inbox Panel links on IE11. It could occur on other browsers too, but I tried Chrome and it didn't occur using that. It is repeatable on IE11, although I'm not sure whether it's a StackOverflow bug or an IE11 bug.

So anyway, I noticed that when I click on a link to a post in the Inbox, it takes me to the relevant page and then nicely scrolls the page to the relevant comment. This is good until I want to scroll the page. After clicking on any link in the Inbox, I can't then scroll on the loaded page. It's not just mouse scrolling that doesn't work either... the keyboard arrow keys no longer work either. Only the PageUp and PageDown keys and manually moving the scroll bar still function properly.

After looking into it a little, I noticed some other things too. If I had earned some reputation for a particular question, I could click on the link to it from the Achievements Panel and still scroll the loaded page. Also, when clicking on a normal link to the same post from a search result, scrolling was not affected. So I took note of the three different links to the same post and then noticed something:

The first link is the normal search result link: Binding an Image in WPF MVVM
It has the format https://stackoverflow.com/questions/id/name

The second link is the link to the answer: Binding an Image in WPF MVVM
It has the format https://stackoverflow.com/questions/id/name/21789092#21789092

The third link is the link to the comment with the bug: Binding an Image in WPF MVVM
It has the format https://stackoverflow.com/questions/id/name/21789092?noredirect=1#comment32970507_21789092

If you have IE11, then you'll be able to scroll the pages navigated to by the first two links, but not the last one, even though all three of them are actually the same page. By looking at the different URLs, it seems as though there could be some problem with the noredirect=1 part. I've seen this faulty functionality from my work computer too, but I'd be interested to hear if anyone else can also confirm this.


UPADTE >>>

Hey guys, I've noticed that this bug also occurs in IE11 on Windows 8, but just in a different place. Instead of using the Inbox links, just edit (not add) a comment... when you press Enter, you see a flashing text entry cursor to the right of the 'edit' link and the page can not be scrolled, unless manually using the scroll bar. In fact, even the PageUp and PageDown keys no longer work.

I found that if you click in one of the comments, the normal scrolling functionality returns. I also noticed that after editing a comment, the page gets that noredirect query string parameter again:

https://stackoverflow.com/questions/id/name/21791103?noredirect=1#comment33042046_21791103

Please note that this also occurs on Windows 7.

  • 1
    Using IE11 on Windows 8.1 - cannot reproduce. Do you have any plugins/add-ins installed? Are you seeing any JavaScript errors in the console? – Oded Feb 17 '14 at 13:37
  • Nope, no plug ins installed. I've just had my computer at work upgraded to Windows 8 and I can no longer reproduce this problem. I can still reproduce it on Windows 7, so please remove that status-norepro tag. I will edit my question to clearly state that this only happens on Windows 7. – Sheridan Feb 17 '14 at 14:03
  • No-repro on Windows 7, IE11. – Qantas 94 Heavy Feb 17 '14 at 14:05
  • Really? That's strange. I'll have another check when I get home. – Sheridan Feb 17 '14 at 14:06
  • No repro, clean IE 11 on Windows 7. Press F12 and then CTRL+2 to activate the JavaScript console then try again. Do you see any errors? – Shadow The Curly Braced Wizard Feb 17 '14 at 14:23
  • I'll have another check when I get home. – Sheridan Feb 17 '14 at 14:26
  • Tried again, IE 11 Windows 7. No repro. – Oded Feb 17 '14 at 17:31
  • Yep fine, I've now re-tested at home on Windows 7 and the problem seems to have been fixed now. Thanks for trying. However, the bug mentioned in my UPDATE is still reproducible. Edit a comment once, or maybe twice and then the page will freeze and you won't be able to scroll. And that is on both Windows 7 and 8. Maybe I should add that as a separate bug? – Sheridan Feb 17 '14 at 18:53
  • Strange, but I do have that problem again... I can't scroll the page after clicking on the Inbox link. Windows 7 and IE11. – Sheridan Feb 18 '14 at 21:55
  • 1
    Is no one listening now that there is a 'StatusNoRepro' tag on this question? This problem definitely still exists. I've had it on Windows 7 and while it doesn't have quite the same effect on Windows 8, it does actually occur... it just affects the scrolling, making it 'stutter'. And all these negative effects can be fixed when I simply remove the query string from the URL. Can someone else please check this for me? – Sheridan Feb 20 '14 at 8:59

You must log in to answer this question.

Browse other questions tagged .