4

When I switch from a normal public SE site to area 51 I am not automatically logged in.

Moreover, the Area 51 page is displayed with some text based formatting, but without frames or pictures. Or, if I do get a normally rendered page, my next click to log-in, or to another page on Area 51 renders in the weird formatted text only mode (see pictures below).

Trying to log in from the non grapichs based page by entering https://www.google.com/accounts/o8/id in the manually enter your openID feild produces the error: Unable to log in with your OpenID provider

I'm running Linux Mint KDE 16, with chromium. The bug persists in incognito mode. And the rendering issue occasionally appears in Firefox as well; however I don't have the same log-in issues with Firefox.

Example of page displayed when visiting Area 51: Text formatting only example

Example of page displayed when trying to log in. Note that there is no logo's to click on to log in: enter image description here

Example of display issue in Firefox while loged in: enter image description here


Related issues with solutions that do not solve this question's problem:

Can't log in to Area 51

Trouble with Area 51 Login

Oops! Something Bad Happened to chat…and login…again

Screen rendering problem

  • Your problem is HTTPS; the CSS and images for A51 are served over HTTP, and cannot be embedded onto an HTTPS page. Disable HTTPS Everywhere for SE and everything should be fine. – michaelb958--GoFundMonica Feb 17 '14 at 1:30
  • I did, and it's not HTTPS everywhere, it's chrome/chromium: support.google.com/chrome/answer/1342714?hl=en – virtualxtc Feb 17 '14 at 1:39
  • Also, while "allowing unsafe scripts" fixed the picture rendering, it did not fix the log in issue. – virtualxtc Feb 17 '14 at 1:40
  • In that case, I don't know. – michaelb958--GoFundMonica Feb 17 '14 at 1:41
  • @michaelb958 turns out the login issue is https everywhere – virtualxtc Feb 17 '14 at 1:42
  • Well there you go. I'm trying to find a viable duplicate, but it isn't letting me... – michaelb958--GoFundMonica Feb 17 '14 at 1:46
  • @michaelb958 I think the chromium sheild issue is actually new; perhaps referencing the https everywhere question in my answer is a better way to go. – virtualxtc Feb 17 '14 at 2:00
3

Thanks to michaelb958 for pointing me in the right direction; it appears this question is a partial duplicate of: Can't login with Stack Exchange OpenID when HTTPS-Everywhere plugin is active - apparent protocol mismatch

This appears to be due to poor coding practices that were caught by a combination of 'https everywhere' and built-in security detection for 'chromium' / 'chrome'

To work around these issues one can do the followng:

To restore pictures:

  • In the address bar click on the unsafe content shield icon: unsafe content icon
  • Click the link to load unsafe scripts
  • reload the page

To restore log-in:

  • In the address bar click on https everywhere symbol: https everywhere icon
  • Under 'stable rules' and 'experimental rules', uncheck the boxes next to the works 'stack exchange'
  • reload the page
|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .