2

In Firefox 29.02a, if a message is starred, and you visit it via its permalink, you won't see its stars in the transcript. This includes the messages in the starred message list on the right hand side of our chat rooms.

As an example, let's take this message from RPG General Chat's starred message list, which has two stars on it:

Two stars: "The problem with D&D is... a great start for any number of sentences, really."

If you click the timestamp, you can visit the message directly in the transcript. It won't have any stars show up for it though:

no star!

But let's take the permalink for, say, the message right above that one and visit that URL instead. The stars show up!

a star shows up!

It's been like this for at least a few weeks.

closed as off-topic by animuson Feb 18 '14 at 17:25

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The problem described here can no longer be reproduced. Changes to the system or to the circumstances affecting the asker have rendered it obsolete. If you encounter a similar problem, please post a new question." – animuson
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Odd, because I can see the star in both examples. What browser do you use? I am using IE 11.. – Nean Der Thal Feb 18 '14 at 9:26
  • Firefox Aurora 29.02a. It seems this is specific to Firefox. – doppelgreener Feb 18 '14 at 9:48
  • Oops, I think this may be my fault. Investigating... – Ilmari Karonen Feb 18 '14 at 14:22
  • OK, fixed in SOUP v1.6.1. Now, the interesting question is, how do we close this? ;-) Is it status-completed, status-norepro or status-bydesign? – Ilmari Karonen Feb 18 '14 at 14:55
  • Whoops; confirmed - this was part of SOUP. I forgot I was using the SOUP script on one of my machines. – doppelgreener Feb 18 '14 at 22:43
1

This appears to be a bug in the SOUP user script caused by the inclusion of this related CSS fix. Specifically, there's another CSS rule that adjusts the star marker placement for highlighted messages which also needs to be overridden to restore proper marker placement.

I've just pushed a hotfix for this issue to GitHub as SOUP v1.6.1. If your browser doesn't update the script automatically, you can install the updated version here.

The fix is also included in the SOUP development branch version 1.7.5, and will be included in the upcoming SOUP v1.8.

  • Shouldn't this issue be migrated here then? – Shadow The Dragon Wizard Feb 18 '14 at 15:20
  • Yes, it should, but I don't think the SE software is quite that flexible. Anyway, I've asked a mod to somehow mark this as resolved. – Ilmari Karonen Feb 18 '14 at 15:25
  • 1
    No-repro fits best in my opinion, for those who don't use the script. – Shadow The Dragon Wizard Feb 18 '14 at 15:31

Not the answer you're looking for? Browse other questions tagged .