1

I have tried to edit a suggested edit, which was approved and later edited. My edit came after that and the system rejected its application as is was deemed less substantive. (I applied it from outside the edit queue later, by the way.)

Then I noticed (via Status Watch addon for Firefox) that strange requests are made to the server periodically, failing with 404 status. The undefined in the request path should be a post ID and I think it comes from undefined JavaScript variable. The variable being undefined seems to be a bug to me.

Request header:

POST /posts/undefined/editor-heartbeat/edit HTTP/1.1
Host: stackoverflow.com
User-Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0
Accept: application/json, text/javascript, */*; q=0.01
Accept-Language: cs,en-us;q=0.7,en;q=0.3
Accept-Encoding: gzip, deflate
DNT: 1
Connection: keep-alive
Content-Type: application/x-www-form-urlencoded; charset=UTF-8
X-Requested-With: XMLHttpRequest
Referer: https://stackoverflow.com/review/suggested-edits/4131292
Content-Length: 55
Cookie: deleted in order to hide sensitive info
Pragma: no-cache
Cache-Control: no-cache
clientRevisionGuid=b94207a5-24e8-47cd-8b91-bbcf87dbc4b7

Response header:

HTTP/1.1 404 Not Found
Cache-Control: private
Pragma: no-cache
Content-Type: text/html; charset=utf-8
X-Frame-Options: SAMEORIGIN
Date: Sat, 22 Feb 2014 11:37:44 GMT
Content-Length: 26893

I am using unsupported Firefox 17.0.11esr. I cannot test it in a more recent browser now. Still I believe this bug does not depend on most modern features. I’ll be glad if someone could confirm that the requests are made even in supported browser versions.

  • BTW list of supported browser versions is here on meta. – Palec Feb 22 '14 at 12:48
  • How are you using Firefox 17? Did you disable auto-updating? We don't support older versions for which bugs have been fixed for a reason... – Nick Craver Feb 24 '14 at 11:54
  • @NickCraver I’m using the ESR version that does not update so often. But I don’t even have the last ESR version, which is 24.0.3 now, because it depends on a newer version of glibc than I have, which is a showstopper for me. Whole my OS is old and I have not found time to upgrade it. I know I have to ASAP but I must prepare in order not to lose my sometimes hacky configuration. I started learning how to use Linux with this installation and now I am in process of cleaning things up so that I can backup everything I need. – Palec Feb 24 '14 at 13:16
  • By the way, I use vanilla Firefox on Debian, not using the packaging system. I found that FF 18 depends on newer glibc by installing the automatic update and not being able to start it. I tried to start it from terminal, got an error message, found a bug in Bugzilla, sweared, decided to downgrade, downloaded the old version using IceWeasel (Debian-rebranded FF) and realized that the IceWeasel uses the same configuration as FF and it completely messed my profile up. >:-( Much data was gone even under manual inspection. FF does not take much effort checking if its actions don’t break anything. – Palec Feb 24 '14 at 13:28
  • Sorry, I meant 24.3.0esr, not 24.0.3. – Palec Feb 24 '14 at 14:14
2

Yeah - there was an issue with the postId not being found by some JavaScript.

I have rectified the issue and the heart will keep on beating, for FireFox and other browsers, starting in the next build.

  • Thanks! I was pretty convinced it was not just a browser version issue. Glad I was right. – Palec Feb 24 '14 at 13:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .