I tried to edit my answer within a few minutes of posting. On the first edit, it shows the first version of the post.

On the next immediate edit, it doesn't show the updated version, but instead still shows the first version of the post.


alt text http://img81.imageshack.us/img81/8978/93838438.jpg

First edit

alt text http://img24.imageshack.us/img24/1538/94284499.jpg

Version after first edit

alt text http://img143.imageshack.us/img143/9314/44605317.jpg

Second edit

alt text http://img170.imageshack.us/img170/5974/67849176.jpg


It worked after clearing the cache after the first edit.Now its showing the updated contents correctly in 2nd edit....

why this??

  • Way vague, are you talking about not seeing full edit history when you do edits? – random Sep 17 '09 at 7:15
  • @random, i have modified the question for better clarity... – RameshVel Sep 17 '09 at 7:21
  • after a minute or so, it updated the edited contents... for a test can i add a new answer to the same(this) question and take a screenshot..?? – RameshVel Sep 17 '09 at 7:24
  • Still not sure what you're bringing up. Just add it to the question even. – random Sep 17 '09 at 7:31
  • random, i have updated the screenshots. pls check out – RameshVel Sep 17 '09 at 7:46
  • 1
    I see it, I see it! Hey, give me my glasses back... Sorry Ramesh, I can't recognise anything! – Ladybug Killer Sep 17 '09 at 7:49
  • @john, hope you dont need glasses now.... :) – RameshVel Sep 17 '09 at 8:05
  • Do you click the "Save Your Edits" button? – Ladybug Killer Sep 17 '09 at 8:09
  • yes, thats the only way. right... this happens only if the duration between the first edit and 2nd edit is in seconds... like within a minute... – RameshVel Sep 17 '09 at 8:17
  • What's your browser/version, OS/version? – Ladybug Killer Sep 17 '09 at 8:22
  • IE 7 and windows XP SP2.. – RameshVel Sep 17 '09 at 8:25
  • 1
    You're using IE? Aaaaaaahhhhhhhhhhhhh! – Ladybug Killer Sep 17 '09 at 8:26
  • yyyyyyyyyyyyy.....??? – RameshVel Sep 17 '09 at 8:59
  • To your edit: because the old version is not fetched out of the cache anymore. – Ladybug Killer Sep 17 '09 at 14:40

My guess is that this is a browser caching issue. The edit link has the same URL from one edit to another, so if your browser is caching too aggressively, it will show you the edit page from the first time you clicked the link (i.e., the first version) on every subsequent browse to that link.

To troubleshoot, I'd try hitting "refresh" after editing the second time to see if it updates your page with the newer version. Also, try temporarily disabling your browsing cache to see if it goes away.

| improve this answer | |
  • Adam, i think you are correct... I just cleared the cache after the first edit and now its showing the updated contents correctly in 2nd edit.... – RameshVel Sep 17 '09 at 13:21

Edit History

If you're talking about what I think you're talking about, it's by design. There's a window -- I believe 5 minutes -- during which if you edit your question or answer, it's not counted as an edit. I believe that is what you're running into here.

(BTW, according to the linked post above, this goes for any edits within a given 5-minute window. Therefore if someone else came along edited this answer within 5 minutes of my adding it -- say to put up a picture of delicious waffles -- it won't show in the edit history.)

This is probably a good thing, given that after you post and have a chance to re-read, you might need to make some quick tweaks. Also, this helps ease the auto-community-wiki situation, as edits you make yourself do count toward your question turning wiki and not earning you rep.

So, correct, you're not seeing edit history.

Edit Not Saving?

If you're implying that your edit didn't save correctly the second time, then that's a whole other story. Looking at the answer you provided for your post, it definitely looks like any edits done were within the 5-minute window, so I can't see history on it, but the only time I've seen issues where an edit didn't "take" was when there was a concurrency issue (multiple users editing simultaneously). That doesn't look like the case with yours, though.

| improve this answer | |
  • More like any subsequent edits within the window are showing only the first version. – random Sep 17 '09 at 12:24
  • John, its different. the link you have mentioned discussing abt maintaining the revision history. "counting all edits in a five-minute window as one edit" . but my problem is the content that i added in my previous edit doesnt shown up in my next immediate edit... – RameshVel Sep 17 '09 at 13:28
  • Then I'd look at your browser cache, as was indicated by Adam. But definitely not an S[OFU] bug then. – John Rudy Sep 17 '09 at 13:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .