3

This question already has an answer here:

This is a silly bug, but I am reporting it anyway.

Steps to reproduce: Click edit on your profile. Then, without changing any fields, click Update.

Result:

Oops! There was a problem updating your profile:

  • temporary error updating your profile -- please try again!

The error message is deceiving, I guess it is thrown because the Update command returned zero affected rows and the result of the update turned out false; just a guess.

marked as duplicate by Shadow The Dragon Wizard, ProgramFOX, michaelb958, Martijn Pieters, psubsee2003 Mar 2 '14 at 11:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • No-repro for me. Must be related to one of the fields being empty. – animuson Mar 1 '14 at 23:41
  • @animuson it happens to me, once I update any field no error when update button is clicked. Tried it on IE, Chrome and FF. – Nean Der Thal Mar 1 '14 at 23:42
  • No-repro for me either... – hichris123 Mar 2 '14 at 3:04
  • 1
    Guys, try it for the second time.. it should reproduce the second time... – Nean Der Thal Mar 2 '14 at 3:06
  • @MeNoTalk Yep, doing it a second time worked. That's weird... – hichris123 Mar 2 '14 at 3:25
  • I got this on dba.stackexchange.com (I was trying to save a change to my profile), but I couldn't reproduce on the main site (where I was able to save my profile successfully). – Aaron Bertrand Mar 2 '14 at 4:37
2

This validation error is thrown when you try to edit your profile too quickly. It's an old throttle, one that's also used when asking/answering questions.

Because we aren't checking to see if there are any changes (we just do an update with what's in the form - simpler that way), we aren't failing early/silently.

I'm going to say this isn't a priority to fix right now; just click "cancel" or don't click "Save Profile" so fast :)

Not the answer you're looking for? Browse other questions tagged .