3

On tag pages on Stack Overflow (e.g. https://stackoverflow.com/questions/tagged/java), I usually get a bar at the top of the questions list indicating "n questions with new activity" that I can click on to load new questions, which appears in near-real-time as new questions are asked. Presumably the same action also adds the (n) in the title of the page also.

However, sometime today this stopped working. I don't get these updates any more. When I refresh the page in my browser, then I see that there are new questions. But if I don't refresh, then the "asked x mins ago" line on each existing question doesn't update at all any more either. Usually it updates pretty fast, so I see "asked 1 min ago" quickly change to "asked 2 minutes ago" and so on.

A couple of times I have refreshed the browser page and then I found out that there was the "+10" green notification box indicating I've been upvoted on one of my answers. My total reputation number on the top bar didn't update until the page was refreshed either. The reputation change notifications aren't working either.

I am on a Windows 7 PC, and I see this behavior now on Chrome, Firefox, and IE.

I opened Chrome's JavaScript Console, and this is what I see:

event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

jquery.min.js:3

It appears that other Stack Exchange sites are affected, because this is reproducible on Mathematics and also right here on MSO.

I don't know if this message is just now starting to appear with this issue or if it was always there, but this appears to be the only indication that something has gone wrong.

It looks like this has happened in the past:

According to ShadowWizard on the second link, that issue was due to "Web Sockets" not working in the browser, but the test link provided, Real-Time Web Test, seems to think that Web Sockets are supported for me.

The revision at the bottom of the page on Stack Overflow is:

rev 2014.3.3.1418

Was this due to a new revision of Stack Exchange? A new version of jQuery? A WebSocket not working? Something else? Please fix these notifications!

7

We are performing maintenance on our socket servers at the moment. They will be back up in another 15 mins.

  • I started receiving normal notifications about 10 minutes ago. Thanks. – rgettman Mar 3 '14 at 23:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .