6

Steps to reproduce are simple:

  1. Click the Stack Exchange™ MultiCollider SuperDropdown™.
  2. Click "edit" besides "Your Communities" section.
  3. Remove all communities:

  4. Click "Save".

Expected behavior: list is empty and stays empty.

What really happens: list is reset back to top 5 sites, as if I clicked "reset to default list".

4
  • 2
    @LowerClassOverflowian nope, if I remove all except one, I have only one site in there. If I remove it, it grow back to the default 5. Commented Mar 4, 2014 at 13:50
  • 6
    How dare you shut out the almightly Stack Exchange network sites?!?! YOUR PUNISHMENT SHALL COME!
    – Doorknob
    Commented Mar 4, 2014 at 13:53
  • I tried removing only 4 items and saved it, works. Again removed the remaining one, it got reset-ted back to 5 items. I think the list is not allowed to be empty(validation).
    – Praveen
    Commented Mar 4, 2014 at 14:43
  • 1
    @Praveen that's correct. Still a bug in my opinion. :) Commented Mar 4, 2014 at 14:44

1 Answer 1

6

This is really by design.

You can basically have a custom list however you want or the default one. Nonexistence isn't really an option.

Why would someone want to do away with the list completely?

3
  • I was just doing it to test, personally don't want empty list but if you give the option to remove, many people will think they can remove them all. Can you show some message at least when trying to save empty list, disable the save button or simply don't let the user to remove when there is only one item? It would be more user friendly. :) Commented Mar 4, 2014 at 15:38
  • showing some validation message, will be nice.
    – Praveen
    Commented Mar 4, 2014 at 15:39
  • I take your point, but it isn't really an error. Emptying your list basically means you don't want a custom list anymore, which results in the default list coming back.
    – Jeremy T
    Commented Mar 4, 2014 at 15:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .