15

Starting about an hour ago: on Stack Overflow I can no longer enter comments (clicking add/show 4 more comments does nothing) and I can no longer get the Help menu to display (e.g., get to Meta).

I'm using IE8 on Windows 7 (similar problems have been reported on IE9 and IE10 as well), and no, I am not using Compatibility mode.

  • When I click comment nothing happens, except the browser page is redisplayed to show the top of the page.

  • When I click Help in the top bar, nothing happens in Stack Overflow: no menu -- unless I am on my user homepage.

  • When I click StackExchange in the top bar, instead of the drop-down menu, it takes me to a generic welcome page for StackExchange, which says "expert answers to your questions".

  • I've tried logging out and back in, and even closing the browser and reopening it.

  • I've tried deleting my browser cache.

  • I've tried clearing the browser cache and cookies for the StackExchange domain.

Behavior appears to be intermittent. If I go here: https://stackoverflow.com/questions/tagged/emacs# and I reload the page, then the site switcher works momentarily. But if I then go here: xcscope responds "File does not have expected format", even if I reload the page, the site switcher no longer works (likewise comment).

Here is an image showing an error with IE10 on SU. The site kicks the browser into compatibility view (mode). I turn off compatibility view. It comes back on again... Then this. (I'm using Chrome to be able to post this now etc.)

  • 8
    Clear your browser cache and cookies, log in and try again. Consider upgrading to a newer browser; Microsoft will stop supporting IE8 in April, and any hope of getting a fix from SE will evaporate then. – Robert Harvey Mar 4 '14 at 16:40
  • 1
    Are you getting any JavaScript errors in the console? Are you seeing any network errors (ie. resources that are not loading)? – Oded Mar 4 '14 at 16:45
  • 1
    Look in the developer tools - F12 takes you there. You may need to reload the page to see anything recorded. – Oded Mar 4 '14 at 16:50
  • 2
    IE8 isn't officially supported anyway, so the chances of getting a fix may already be slim: meta.stackexchange.com/questions/56161/… – Chris Laplante Mar 4 '14 at 16:52
  • 1
    @LowerClassOverflowian: IE8 is the last version that supports Windows XP. I would not be surprised if this is the case for OP. – nhahtdh Mar 4 '14 at 16:59
  • @ChrisLaplante - with IE 8, we will ensure functionality is preserved. We don't care too much about some visual glitches, however, so long as they don't interfere with functionality. – Oded Mar 4 '14 at 17:10
  • I have tried IE 11 in IE 8 mode, but couldn't reproduce. Have you been able to take a look at the developer tools and see if you see any JavaScript errors or network errors? – Oded Mar 4 '14 at 17:15
  • @Oded: That's all I would ask for. And as you can see, somehow comment is working again. – Drew Mar 4 '14 at 17:15
  • What about the help and Stack Exchange site switcher? – Oded Mar 4 '14 at 17:16
  • 1
    comment is now working for me again here (Meta) but not yet on StackOverflow. – Drew Mar 4 '14 at 17:17
  • 1
    @nhahtdh latest Chrome and Firefox still install fine on XP though. – Martin Smith Mar 4 '14 at 17:54
  • 3
    I am getting the exact same problem this morning on IE9. – Cyberherbalist Mar 4 '14 at 18:02
  • 1
    See my update. SE, SO etc. are totally unusable for IE10 - for me at least. Does anyone see something different for IE10? (I'm posting this from Google Chrome.) Hard to believe that SE does not seem to be taking this breakage very seriously. – Drew Mar 5 '14 at 2:39
  • 1
    @Shog: F12 on SE shows me this in the console window: SCRIPT438: Object doesn't support property or method 'indexOf' full.en.js, line 168 character 184. Does that help at all? – Drew Mar 5 '14 at 3:53
  • 1
    @Shog et al: I have upgraded from IE10 to IE11. The problems I had with SE sites have disappeared, and I was able to keep all of the Type 1 fonts I have (and need). Thanks for all the help, esp. Shog's pointing me to the Bobby Jones article about the Helvetica problem. I guess this issue remains open for IE8 and IE10, but at least I am a happy camper once more. ;-) I have been informed that some other, non-SE sites are problematic wrt IE11, but so far things are much better than with IE10. Thx again. – Drew Mar 5 '14 at 23:29
13

First, we cannot support IE 8. If it works, great - if it doesn't, upgrade: at this point, you're three versions behind current, and likely running into problems elsewhere too.

Second, make double-certain you're not dropping into "IE7 compatibility mode" when this occurs. I'm not accusing you of turning it on - I'm suggesting IE is turning it on in response to something on some pages. If you can identify what this is, it might be possible to fix. The vast majority of the problems we run into with IE are caused by compatibility mode - everyone thinks they have it turned off, somehow it turns itself on. Instructions for disabling it can be found here.

Third, just wait. At least a few people who originally encountered this problem have now seen it go away - with no changes on our end or theirs. Don't really have a good explanation for this, but hey - worth a shot.

  • 3
    What proportion of site users are still on IE8? – Martin Smith Mar 4 '14 at 17:47
  • 2
    (Great, I was able to add a comment here.) The very page you point to as expressing the SE policy on browser support says the opposite of the text you used for that link ("we cannot support IE8"). That policy page says that you will continue to support current and previous versions of all browsers that have some reasonable market share. – Drew Mar 4 '14 at 18:06
  • 4
    @Drew 4.24% according to this. Up to the team here, which Shog represents, to decide if it's considered reasonable or not. – Shadow The Curly Braced Wizard Mar 4 '14 at 18:43
  • 1
    I use IE8 at work (I have to... at least we finally upgraded out of Win XP this year). I've been having intermittent problems with commenting and accessing vote counts. Hopefully we'll upgrade to IE9 soon, but with so many of our aging core web applications (third-party vendors) simply not working on newer versions of IE, it's not likely to be soon. – JDB Mar 4 '14 at 19:01
  • 1
    @JDB Well looks like it is broken on IE9 anyway so that won't help! – Martin Smith Mar 4 '14 at 20:47
  • 4
    @ShadowWizard: Add in the numbers for IE10 and IE9 (and IE11?). And take a look at browser use on desktops, which might better represent people at work, including developers: 58% IE. And that includes 26% IE8, 17% IE9, 0.16% IE10 – Drew Mar 5 '14 at 2:47
  • 2
    @Drew I'm not sure how you got those percentages for IE version distribution. If I click that link, I see this: IE8 21.73%, IE9 8.8%, IE10 8.04%, IE11 12.8%. In other words, two in five IE users have an SE-compatible IE10 or 11. Here's a screenshot. I didn't fiddle with anything, just clicked and looked. – doppelgreener Mar 5 '14 at 7:23
  • @Jonathan: Yes, well, I guess it changed from earlier today? I see the same as you now. Odd. However, IE10 is apparently not compatible with SE - please read what I've written above. I am using Google Chrome to enter this comment. With IE10 I cannot even see most of the page, let alone do anything with it. It automatically kicks into Compatibility mode. – Drew Mar 5 '14 at 7:32
  • @Drew well, IE10 is supported so this is a bug that should be fixed. – Shadow The Curly Braced Wizard Mar 5 '14 at 7:33
  • 1
    Sorry Microsoft still supports Vista for a few years, and IE9 is the limit of what will run on Vista. Your policy is saying that someone must install custom access software to use Stack Exchange sites, it is just like a shop refusing to let anyone park if they have a car that is over a few years old. – Ian Ringrose Mar 5 '14 at 9:40
  • 3
    @Ian That's a terrible metaphor and you know it. Does a shop need to make modifications to their parking lot to let older cars park there? – Stijn Mar 5 '14 at 12:34
  • 2
    No one's trying to shut you out, @JDB - with the possible exception of your own IT dept. Look, I'm more than familiar with working for organizations where you have to break the rules just to get your job done, but that's neither here nor there. 'Fact is, you're likely prevented from upgrading for the same reason: your team isn't able to support another browser version. When I say it's not feasible to maintain support for increasingly-obscure browsers, it has nothing to do with shutting anyone out - it's purely an observation of the impracticality of trying to do otherwise. – Shog9 Mar 5 '14 at 15:02
  • 3
    @JDB: as has been noted here several times, we didn't change anything that should've affected this. We've actually been rather careful to avoid functionality we know doesn't exist in older versions of IE - and yet, it broke yesterday for a handful of people. So what can we do about that? If I was still working in Corporate IT, supporting all of two versions of one browser, I'd have VMs set up with every permutation of Windows, IE and recent patches along with the standard LOB apps - but of course that's not feasible to do for the entire Internet audience. – Shog9 Mar 5 '14 at 16:09
  • 1
    Hey, @Oded - for the year and a half before this week, it was IE8 on Windows XP. This is an "upgrade!" – Josh Darnell Mar 5 '14 at 17:12
  • 2
    @jadarnel27 - OK. May $deity have no mercy on your employer ;) not brown, not brown at all. – Oded Mar 5 '14 at 17:14
11

I wanted to comment on the answer to say "Me, too!" but on IE9, but because I was having the same problem (can't enter comments) I had to do it with an answer. SE then took my short answer and converted it to a comment, so great.

But I wanted to say that for some reason I cannot even log in using Stack Exchange on FireFox 26.0.

I am entering this answer via Chrome because I can't put in comments using IE9 (nor can I click on up/downvotes to see the breakdown).

I cannot upgrade to IE10 because my employer's policy -- we're supposed to upgrade no higher than ie9, and our internal apps must support IE6 - 9.

  • IE6? Ouch... I hope you get paid extra for that. – Ilmari Karonen Mar 4 '14 at 21:47
  • 5
    Nope. :-) It happens that IE6 is almost gone away here. But it's a state gov't intranet with 40K users, so there are a few holdout agencies that apparently think they are still in the buggywhip manufacturing business. – Cyberherbalist Mar 4 '14 at 21:55
10

I have to agree with @Cyberharbalist. My employer dictates what version of IE I use and I have to have it in compatibility mode due to some internal applications I must use. If this change is not reversed, I will have to consider leaving SO as I cannot upgrade my work system for valid work reasons. This was a shortsighted change that doesn't reflect how non-IT based companies work. Lots of us work in other business domains.

And what is with the unreadable CAPTCHA stuff today? You need to test that with people who have bifocals for goodness sakes.

Edited to answer comment. No of course they do not let us install any old software we want. The business world doesn't work that way even if it does in IT only shops.

What bothers me most about this change is that all the stuff that broke is not new, it is stuff I have been able to do all along. Why gratuitously break it without any new functionality? What kind of poor project management is that? We try not to break stuff that works unless we have to make a change. Why aren't you doing the same? And please remember that on the other SO sites, eventually the majority of users may not be IT people. Non-IT people avoid upgrading as much as possible. What you are doing is throwing away contributors for what seems to be no valid reason except you only want to support the newest.

  • Don't they let you install Firefox or Chrome? – Stijn Mar 4 '14 at 19:17
  • 2
    @Stijn : I happen to be a dev and have privileges of installing whatever darned software I want to install (they trust us not to be stupid - a dubious proposition I will admit). So for the sake of making sure my stuff works everywhere, I have every browser from IE to Opera and even Sleipnir. Most of the non-dev people in my organization do not have this privilege, and don't have admin authority on their own machines. – Cyberherbalist Mar 4 '14 at 21:50
  • 2
    @HLGEM: It actually takes a significant amount of resources to support older versions of browsers, and comes with significant loss of ability to provide the best features for people keeping up with versions. This isn't a matter of just wanting to support the newest. – doppelgreener Mar 5 '14 at 3:16
  • 1
    @JonathanHobbs: Older versions of browsers? So IE10 is now too old to support? I would have upgraded to IE11, but I know there are sites I need for work that do not support it. Had I guessed that SE would be worse (completely unusable) with IE10 than IE8, I never would have upgraded today. – Drew Mar 5 '14 at 7:05
  • @Drew No, IE10 is supported and it's a legitimate concern that IE10 is not working for you. IE8, however, is an older version. If you want help regarding your IE10 issue, I suggest you open a new question about it. This question has been fundamentally about IE8, not IE10 - until the most recent edit. This isn't to hassle you: you'd actually be better off asking about your IE10 issues on a clean slate, free of the IE8 context. – doppelgreener Mar 5 '14 at 7:14
  • @Jonathan: Maybe, maybe not (it would be better etc.). I don't see this as fundamentally an IE8 issue, though that is how I titled the question at the outset. The page that talks about font incompatibility says that it is a problem for IE9, and I see it for IE10 too. SE seems pretty broken for IE altogether, judging from what I have been through today. – Drew Mar 5 '14 at 7:34
  • 5
    "Why gratuitously break it without any new functionality" - we didn't. Or at least, not intentionally. And non of us who tried are able to reproduce the breakage either - it is clear some people are having problems (IE 8/9/10), but others, using the same browsers, are not. I would love to get down to the bottom of this and get it sorted out for everyone. //cc @Drew – Oded Mar 5 '14 at 11:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .