When I tried to run How many upvotes do I have for each tag?, I got the below screen:

The captcha is missing! I tried in other browsers too.


From @Oded's comments, I changed to HTTP and it was working perfectly. Out of curiosity I would like to know why the captcha isn't working when accessing Data Explorer over HTTPS.

  • Are you connecting over https? – Oded Mar 5 '14 at 15:37
  • 1
    @Oded yes, the link points to https. I've asked this before in another bug report but didn't get an answer, why do you guys have https enabled when it's unsupported/broken? Why not just force redirect to http and avoid all these bug reports? – Stijn Mar 5 '14 at 15:37
  • 2
    Try without https - we are not yet fully converted to https and things like the captcha might not work. – Oded Mar 5 '14 at 15:38
  • @Oded without https, it is working :) – Praveen Mar 5 '14 at 15:40
  • @Oded looks like many people reach the https:// version of Data Explorer via Google, see this. Can you, or other developer, contact Google and ask them to change this, explaining it break things for those users? – Shadow The Princess Wizard Mar 31 '14 at 8:45
  • @ShadowWizard - given that Tim Stone fixed the issue, once we deploy the fix all should be good. – Oded Mar 31 '14 at 9:03
  • @Oded hmm... I fear it still might break things, for example clicking the Stack Exchange logo (in the top bar) brings the user to https://stackexchange.com/. Does the main portal stackexchange.com also supports HTTPS by now? – Shadow The Princess Wizard Mar 31 '14 at 9:06
  • Not strictly, it doesn't (you will get mixed content warnings, though the cert is fine). @Sha - as you know we are still on a long journey towards https... – Oded Mar 31 '14 at 9:08

As alluded to in the comments, HTTPS support on the Stack Exchange network is not complete yet, so you're bound to run into some issues when using it. However, I've gone ahead and addressed the specific issue with reCAPTCHA, pending a pull and redeployment of Data Explorer.

  • Hey Tim see my comment above, can you change it so the link to Stack Exchange portal is absolute and will always point to http://stackexchange.com/ even when browing https://data.stackexchange.com/? I got a feeling that stackexchange.com will cause things to break e.g. scripts will fail loading. – Shadow The Princess Wizard Mar 31 '14 at 9:20
  • 1
    @ShadowWizard Hm...I'm surprised Google gives that link to Data Explorer. That might be a good reason to change it then, yes...I'll make a note. – Tim Stone Mar 31 '14 at 14:26
  • Well, turns out it's not new behavior. See this, can you use the suggested work around? – Shadow The Princess Wizard Mar 31 '14 at 14:30
  • @ShadowWizard Perhaps, although for Data Explorer at least it's probably fairly easy to just make it completely work with SSL since that's the endgoal anyway. – Tim Stone Mar 31 '14 at 14:33
  • Yeah, but that's not the issue, it's the links out of DE that concern me the most. – Shadow The Princess Wizard Mar 31 '14 at 14:37
  • Seems to have cropped up again – asheeshr Apr 12 '14 at 6:06
  • @AsheeshR - The update is not deployed yet. The last deploy was on 2014-02-03 (Found from the footer of the Data.SE site). – hims056 Apr 12 '14 at 6:09
  • 1
    @hims056 Oh, didn't know. Thanks! – asheeshr Apr 12 '14 at 6:11

The SE page is over https, captcha content is loaded over http. By default the browser will block the unsecured content in https pages, unless you explicitly allow it:

enter image description here

or simply try the http link for the same page

  • But I didn't get any popup like yours. Might be problem with my setting. – Praveen Mar 5 '14 at 15:43
  • 1
    Yes, in the security options of IE set the "allow mixed content" to prompt instead of disabled. Remember, security settings can cause problems, do it on your own risk :) – Nean Der Thal Mar 5 '14 at 15:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .