3

I've just had several delightful moments of "oh crap I can't use my account anymore." I even telecommuted to work to use my office PC where I'm still logged in to SO to write this question, but then I figured it by accident.

So I had to clear my browser cache.
Then I tried to log in with my usual LiveJournal OpenID (which I do by clicking the pencil icon and typing just my LJ user name in the small box), but Stack Overflow would keep saying in a red box:

No OpenID endpoint found

I tried several times, one time I instead got that in a similar red box:

OpenIdIdentifierRequired

but otherwise it was consistently the former.

Turned out, when I enter my LJ user ID into the small box, the big box is auto-populated with https://<correct path to LJ OpenID>, and that link fails. To fix it, I had to go 'Back' and manually change https:// to http://, only then it logged me in.

Please fix the auto-population to use http:// in the first place.

Possibly related:
Why can't I use my openid with HTTPS? Why does it have to be HTTP? Is it because my HTTPS cert is from cacert?

3

Thanks for reporting.

Didn't expect an openId provider that doesn't support https - in particular a large one such as LiveJournal.

This default has been changed and will be with you in the next build (rev 2014.3.13.1453, meta rev 2014.3.13.2051).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .