16

When linking a question via HTTPS, the question doesn't appear in the Linked Questions sidebar.

In the question My avatar automatically changed, this was the initial screenshot:

Initial sidebar

So then the question was edited to use HTTP in the link instead of HTTPS: Revision history

After that, the question is now shown in the Linked Questions sidebar: Final Sidebar

I've also repro'ed this in a comment on this post: Meta is... Japanese?. So if you use HTTPS in the URL, it doesn't link the posts. However, if you use HTTP instead of HTTPS, it works. Can this please be fixed?

  • HTTPS isn't fully supported yet. – Adam Lear Mar 25 '14 at 3:42
  • @AnnaLear True, however this isn't so much a problem with HTTPS everywhere or anything. I'm assuming the system just isn't detecting links with HTTPS to link them together. – hichris123 Mar 25 '14 at 3:44
  • 1
    Sure, but we don't support HTTPS Everywhere and I personally hesitate encouraging HTTPS links until we actually expect them to work 100% of the time. – Adam Lear Mar 25 '14 at 3:49
  • Similar, but already fixed, issue: https links to same site don't auto-prettify – Ilmari Karonen Mar 25 '14 at 17:15
  • 2
    Also, it would be really nice if this could be made to also work for protocol-relative links. – Ilmari Karonen Mar 25 '14 at 17:18
  • 1
    @Anna won't it be easy enough to strip the https in the linked sidebar and link only to the non secured version? – Shadow Feb 10 '15 at 13:10
  • @ShadowWizard Actually, stripping http/https from all SE links, making them protocol-relative, would be a good idea. – Deduplicator Feb 10 '15 at 15:28
  • @Deduplicator sure, but I'm talking only on Linked questions in the sidebar as a temporary workaround, which hopefully is faster to implement. :) – Shadow Feb 10 '15 at 15:30
  • @Deduplicator Not a good idea until we do support HTTPS across the board. It sort of usually works on main sites, but meta sites can't support it at all, so protocol-relative links from HTTPS main to meta are always broken. Having said that, protocol-relative links are on our list. – Adam Lear Feb 10 '15 at 15:52
  • @ShadowWizard Not sure off the top of my head how Linked question list is built/maintained, but this doesn't look like a display bug. – Adam Lear Feb 10 '15 at 15:53
  • looking into this, the links in the linked sidebar are already relative to the current page (like in /q/{id}) – m0sa Feb 10 '15 at 15:53
  • protocol relative links are not picked up as links by the comment mini-markdown – m0sa Feb 10 '15 at 15:56
  • @m0sa thanks for looking into this! Anyway, it's not protocol relative, if I now post https://meta.stackexchange.com/questions/248382/chat-link-in-top-bar-is-not-site-specific which is meta.stackexchange.com/questions/248382/… it will not show as Linked. Probably the protocol is being removed somewhere in the code? – Shadow Feb 10 '15 at 16:00
  • @ShadowWizard I was saying that all the links in the Linked section are already relative (not in the actual comment/post though) – m0sa Feb 10 '15 at 16:16
10
+50

Https links will be picked up as linked posts after build rev 2015.2.10.3062 on meta and 2015.2.10.2282 on sites roll out. They will be rendered as relative in the linked sidebar. In the actual post/comment they will still be rendered as they were entered by the author.

Protocol relative URLs are not rendered by the markdown engine as links, I see no need to add support for them in the linked post detection.

  • 3
    If you got a minute, can you please elaborate on the "why" part here? – Shadow Jun 16 '16 at 21:18
  • 1
    With regards to "I see no need to add support for them in the linked post detection" - What about in linked references i.e. [1]://meta.SE... – Jeff Puckett Jun 16 '16 at 21:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .