I wanted to ask my first question and after editing, I pressed the Ask Your Question button which become disabled and I couldn't press it.

I don't see any error messages on the page and the question is not on my asked questions list. I also don't see the question appear on the new questions page.

What did I miss?

screen shot of broken ask button

  • Could you elaborate on what you did exactly. You asked a question, went to edit and clicked the Ask a question button? – Ólafur Waage Sep 20 '09 at 21:33
  • - I entered the Title - Wrote the question - added some tags - and pressed the button (it is under Opera 10) – Vereb Sep 20 '09 at 21:38
  • Definitely the right button? I've had no problems here with Opera 10 – MartW Sep 20 '09 at 21:41
  • I could ask question here in meta and I pressed the same button – Vereb Sep 20 '09 at 21:44
  • A link to your account would be useful. – Brad Gilbert Sep 20 '09 at 21:51
  • superuser.com/users/11017/vereb – Vereb Sep 20 '09 at 21:56
  • i added a screenshot – Vereb Sep 20 '09 at 22:13
  • Do you have scripts allowed? ( specifically from sstatic.net and google ) – Brad Gilbert Sep 20 '09 at 22:32
  • 3
  • 1
    Yo, Freehand Circles, I'm really happy for you, I'ma let you finish, but Vereb had one of the best substitutes for you of all time! – Michael Stum Jan 24 '10 at 19:51

We moved most of the post validation to the server, which reduces the chance that JavaScript quirks will disable the submit button. Also, any submission errors can be simplified and placed in the same area on the form:



Happens to me all the time in Opera. If you've had a popup once (like, you forgot a tag) then the Post Your Question button is grayed out permanently.


Something seems to have been broken with stackoverflow's scripts, I did get a "Content Encoding Error" in Firefox if I tried to load the scripts directly:

The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

The wrongly encoded scripts got cached, but a Shift-Reload fixed the problem.

  • ctrl+f5 for me – bobobobo Sep 21 '09 at 0:58

I had this problem once, no idea what happened then. I think I just reloaded the ask-a-question page.

  • Was your title too short? – bobobobo Oct 5 '09 at 13:58

Yea seems like its a Firefox thing, if the disabled attribute is on the button, even if the value is not set to "true", the button will be disabled.

So I just use Firebug and remove the disabled attribute.


I had this problem some minutes ago. I discarded question, refilled the question form. Closed, reopened browser. I made Ctrl+F5. But the issue is same.

Then I logged out and logged in to site. And it worked!


I just got this in Safari 6.0.5

It seems to be a pan-browser thing based on what you all say.

One cause seems to be editing the tags and the tag-completion breaks. That's how it happened to me.

The fix was to quit the page (multiple times) and reopen it (contents are restored from browser cache). Then the button is working again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .