I'm from China and using goagent to access some blocked websites.
But recently I can't login to SO.

enter image description here

As you can see, connection to cdn.sstatic.net timed out.
But if I use goagent to direct connection to cdn.sstatic.net
(Edit: Explanation-connection will be directed to the goagent server hosted on Google App Engine, and the data would be sent from GAE to bypass the blocking)

enter image description here Because it uses https so I can't use goagent to access it.

Tried ping cdn.sstatic.net on both my Linux system and Windows system, 100% packet loss.

Maybe you'd wonder then how am I posting this question? I logged into SO while I was in US and the cookie's still there. I don't even dare to logout because I probably can't login again.

Can someone help? As far as I know, many, many Chinese programmers rely on goagent to access blocked websites and it'll make their life much harder if they can't login to SO :-(

  • Maybe it's related to the login recently moving to https and the "goagent" can't handle it just yet? Apr 3, 2014 at 7:53
  • @ShadowWizard Yes I guess so.
    – octref
    Apr 3, 2014 at 8:22
  • @AdityaPatil I'm sorry but I don't see your logic. The majority of the people who'd be able to help with my programming-related questions doesn't belong to the 33% population.
    – octref
    Apr 3, 2014 at 8:24
  • @octref India and china have most developers. Apr 3, 2014 at 8:25
  • @octref I just wanted to say that don't break laws and rules, that would only create problems. It was just a suggestion, it's up to you what you do. Apr 3, 2014 at 8:26
  • @AdityaPatil When did our government stand on the moral high ground by blocking facebook, twitter, wikipedia, wordpress, even GOOGLE and now even SO? And why would browsering-SO-to-learn-programming be comparable to pirating-some-xyz-software?
    – octref
    Apr 3, 2014 at 8:44
  • @AdityaPatil Yes, but most of the good developers in India and China use SO MUCH more frequently. In most of the Chinese forums, you can't get a reply in 1 day.
    – octref
    Apr 3, 2014 at 8:47
  • @octref I think I need to explain my though because no one here is understanding what I want to say.1.blocking good sites(like google & SO) is not good, whichever country does that. 2.What I hear about chinese govt, they can be very cruel to law breakers 3.I am not comparing SO with piracy. 4.chinese firewall and the people working behind it are very good, my ethical hacker friends tell me that, so your efforts to bypass it won't last very long. 5. so it would be better that you find local solutions, so you won't be in any trouble. 6.I don't intend to blame anybody here. Apr 3, 2014 at 8:51
  • Maybe related: meta.stackexchange.com/questions/225966/… and the What else do I need part
    – rene
    Apr 3, 2014 at 8:54
  • @AdityaPatil Sorry i misunderstood you. But to my knowledge, programmers in big Chinese tech companies like Ali, Tencent, Baidu are also bypassing the blocking. If you just bypass the blocking to access Google and SO I'm 100% sure it's fine. They just don't want most people to easily access some "sensitive content".
    – octref
    Apr 3, 2014 at 9:01
  • @octref If it's so, then good luck.I am not a very good programmer, but probably, it's problem goagent.Have you tried reporting bug or contacting the developers? also maybe there are other apps like goagent, there are always hidden gems to be found. Apr 3, 2014 at 9:06
  • 1
    After looking through this question, I looked in to GFC(great firewall of china) and got through this link and it seems they allow stackoverflow. I'm not sure about it.
    – Praveen
    Apr 3, 2014 at 9:08
  • 1
    @Praveen This is the problem. greatfirewallofchina.org/index.php?siteurl=cdn.sstatic.net
    – octref
    Apr 3, 2014 at 9:12
  • @AdityaPatil Thanks, but I'm sure it's not goagent's problem. I mentioned in the question I can't ping to cdn.sstatic.net.
    – octref
    Apr 3, 2014 at 9:13

2 Answers 2


Sorry guys. The problem probably does not come from China's web blocking.
The APCN2 submarine cable was broken, and, as a result, some websites became unreachable or really slow in many Asia countries.
News here
Other news say the cable would be fixed before Apr, 4th.
And today, Apr 4th, My computer could connect to cdn.sstatic.net without problem.

Thanks for the attention and help.

  • 1
    Thanks for letting us know! Apr 4, 2014 at 3:37
  • 3
    That explains quite a bit of things I was seeing too (coming from The Philippines and a PLDT subscriber)
    – Tim Post
    Apr 4, 2014 at 3:46

I can't give you a definite solution, but I can offer a possible work-around. Hola seems to be working for other users that have reported issues accessing the CDN from Mainland China.

That's .. unfortunately our reply to most cases like this since it's not possible to troubleshoot this issue from your side to see what works - just continue trying a variety of proxies until you get one that works.

The reason I've been recommending Hola to people is the option it gives you to change VPNs on the fly. If local servers don't get through, UK ones may, or even US/AU/PH/HK. Your best bet is probably the HK pool, when it's available.

(Disclaimer, I'm an avid user of Hola, and this is my personal recommendation. There is no relationship between Hola and Stack Exchange.)

  • 2
    This is clearly a bug with China, bug reports should be send here: mps.gov.cn/n16/index.html
    – yannis
    Apr 3, 2014 at 11:58
  • 1
    I did not know a bug tracker for that existed.
    – Tim Post
    Apr 3, 2014 at 12:38
  • Love that the chinese ministry for public security website has an image that bounces around the window :P
    – OGHaza
    Apr 3, 2014 at 14:39
  • @TimPost Thanks. I spent some time investigating the issue and this might be the cause. According to reports the cable should be fixed by Apr, 4th. If the problem would disappear after Apr, 4th I'll update my question here. Thanks for the recommendation, although I've just bought a VPS and set it up as a VPN to connect to SO.
    – octref
    Apr 3, 2014 at 14:51
  • 2
    @Yannis Bug confirmed. I'm using the newest 2014.4 version :-)
    – octref
    Apr 3, 2014 at 15:11
  • Hola is not working for me in Pu'er, Yunnan as of the end of May 2015. May 31, 2015 at 15:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .