3

This question already has an answer here:

When I try to access meta.*.stackexchange.com via HTTPS, I get a warning:

meta.codegolf.stackexchange.com uses an invalid security certificate.

The certificate is only valid for the following names:

*.stackexchange.com, stackexchange.com, meta.stackexchange.com, stackoverflow.com, *.stackoverflow.com, stackauth.com, sstatic.net, *.sstatic.net, serverfault.com, meta.serverfault.com, superuser.com, meta.superuser.com, stackapps.com, openid.stackauth.com, *.meta.stackexchange.com

(Error code: ssl_error_bad_cert_domain)

I'm using HTTPS Everywhere, but disabling it for Stack Exchange prevents me from logging in to the aforementioned meta sites—I simply get dropped back without being logged in (also, trying to ask a question causes a redirect loop).

Adding a security exception does work, though. Maybe this is because I'm already logged in to other Stack Exchange sites via a secure connection?

Update: It appears disabling the entry for Stack Exchange in HTTPS Everywhere then logging out and logging in again solves the problem of not being able to log in. See balpha's answer for details.

marked as duplicate by 3ventic, hims056, Azik, michaelb958, Aziz Shaikh Apr 25 '14 at 5:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Perhaps relevant: "Stackoverflow.com: the road to SSL". – senshin Apr 23 '14 at 12:03
  • Thanks, you might want to submit that as an answer. Here's the particularly interesting part: What about meta.*.stackexchange.com? Damn. Can’t do that. You can’t have a wildcard of that form – at least not one supported by most major browsers, which means effectively it’s not an option. – nyuszika7h Apr 23 '14 at 12:10
  • Never mind, @balpha was faster with that. :P – nyuszika7h Apr 23 '14 at 12:18
5

Once we officially support HTTPS, we'll probably move meta.*.stackexchange.com to *.meta.stackexchange.com. For details and reasons, see Nick's blog post.

Right now, HTTPS kind of works, but is purely for testing and not officially supported yet.

  • Thanks. It appears disabling the entry for Stack Exchange in HTTPS Everywhere then logging out and logging in again solves the issue. – nyuszika7h Apr 23 '14 at 12:19
  • And yet it doesn't seem possible to login through http on my phone due to automatic redirects. – John Dvorak Apr 23 '14 at 17:21

Not the answer you're looking for? Browse other questions tagged .