Yesterday stackexchange (or at least part of it) was (briefly) in read-only mode, during that time on the website there was a banner indicating that the site was in read only mode. However withing the iOS app there was no such indication, worse if you tried to take some action (I only tried voting, but I'm assuming other actions would have been the same) it would fail without saying why.

  • 2
    +1 - Good idea. This isn't that frequent, but we do it enough (generally to ensure you can access info, but we never lose new content you create) that it would make sense to add in an update.
    – Jaydles
    May 7, 2014 at 13:48
  • Presumably this would be the same for the Android app?
    – ChrisF Mod
    May 7, 2014 at 13:51
  • @ChrisF probably, but didn't think to ask someone to test that at the time. If someone can confirm that it is the case then this question can be edited to reflect that.
    – Jack
    May 7, 2014 at 14:03
  • 1
    @Jack I tested the read only thing with the Android app previously but it was still in the alpha/prerelease stage at that point. It didn't know what to do with itself, crashed and burned. It's probably better now, but I'd be willing to bet there's no indicator.
    – Steven V
    May 7, 2014 at 15:40
  • The iOS app no longer crashes and burns, but implementing some sort of indicator that the site is in read-only mode might be a nice to have at some point. Bonus points for a useful link like meta.stackexchange.com/questions/231126 asks for
    – bmike
    Jun 12, 2014 at 18:02

1 Answer 1


The best indicator would be one that would say, upon attempting an action that would require write access:

The site is currently in read-only mode. You may still take this action, but it will be queued and performed later, and not immediately.

Thus allowing one to continue to vote, compose answers, questions, and comments.

But, of course, this will take more work than a simple, "The site is currently in read-only mode. Please try again later, or visit [someurl] for additional information."

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .