2

Every time I expand comments in SO (using Google Chrome), they overlap with the text on the side panel, making them impossible to read.

Is there any way to fix that?

This seems only to be a problem in Chrome.

Here is an example:

Are there legitimate "fix my code" questions?

  • 2
    Not seeing anything wrong in Chrome version 34.0.1847.131, what version are you using? – Daanvn May 8 '14 at 12:32
  • @Daanvn 34.0.1847.131 is the version I use. Try to click to expand the comments - then you see it. – Dmitri Zaitsev May 8 '14 at 16:13
  • I really can't seem to find anything that's wrong/odd, could you maybe add a screenshot? – Daanvn May 9 '14 at 7:20
  • @Daanvn Here is a screenshot: cl.ly/image/3u2r3d2O0n1e – Dmitri Zaitsev May 9 '14 at 14:57
  • Norepro on Chromium 34 / Firefox 29 on Linux. Your screenshot looks very much like this bug, though. Does it still happen for you? If not, there might've been an over-wide comment that got deleted. If it does, check if you have any user scripts or styles or browser extensions that could be causing it. – Ilmari Karonen May 29 '14 at 0:40
  • @IlmariKaronen It does happen consistently on each Chrome I use, both Desktop and Laptop, every time I expand the comments. It does not even need to contain a long line like in that bug description. – Dmitri Zaitsev May 30 '14 at 15:02
  • There's something else funny about your screenshot: the font size for the comments and the related questions in the side bar looks huge, while the font for the hot network questions sidebar is tiny by comparison. Are you sure you've got no extensions installed that might be messing things up? Does it also happen in Incognito mode (which disables most extensions)? – Ilmari Karonen May 30 '14 at 15:08
  • @IlmariKaronen It is true that Chrome's look is funny even in Incogito mode: cl.ly/image/1c1Z3C1z3V3b, here the words "answers" and "views" overlap and don't fit in the box. However, the bug itself disappeared now, however, it re-appears when I click on "add comment" – Dmitri Zaitsev May 30 '14 at 19:30
  • Related / duplicate bug for Firefox: meta.stackexchange.com/questions/192796/… – Ilmari Karonen Sep 25 '14 at 18:45
2

I still can't reproduce this on Chrome, but I did find a way to repro it on Firefox, using its "Zoom Text Only" feature. The steps are:

  1. Switch to "Zoom Text Only" mode.

  2. Zoom in a few times.

  3. Go to a post with comments, and click the "add comments" link to bring up the new comment entry form.

What happens is that, when you zoom in in text-only mode, the comment entry form becomes wider, but the main content column width does not increase to accommodate it. This causes the form to overflow the column, and, since it's wrapped in the comments table that has a flexible table layout, the table expands along with it, letting the existing comment widen too:

Screenshot of overflowing comments

Anyway, it turns out that the comment overflow fix in the Stack Overflow Unofficial Patch user script, originally written to fix a different issue, solves this one too. With SOUP installed, the result looks like this:

Screenshot with SOUP installed

The comment entry form still overflows into the sidebar, but the existing comments stay within their designated bounds.

Anyway, I still have no idea how to trigger this issue on Chrome without extensions, but at least I know what's happening and how to fix it.


Edit: OK, I did find a way to do reproduce this on Chrome. Apparently, buried in the "advanced settings", there's an option to adjust the font size, which seems to behave pretty much like Firefox's text-only zoom does. Choosing a "Large" or "Very large" font size will produce this effect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .