27

Whenever I try to flag or close a question here, when clicking the submit button the button gets disabled, three dots animating and nothing really happens.

JS console show a single error:

Flagging:

Uncaught TypeError: Cannot read property 'flagSubmitting' of undefined

Closing:

Uncaught TypeError: Cannot read property 'closeSubmitting' of undefined

Please fix, programming questions and spam are beginning to pile up. :(

Update: appears to work fine from within the review system, but otherwise it's the same on Stack Overflow as well

  • 3
    I thought it was just my connection. – Flexo May 15 '14 at 7:12
  • @Flexo nope. When in doubt, check the Console. :-) – Shadow The Dragon Wizard May 15 '14 at 7:12
  • I'm also seeing this on Stack Exchange, although the console error is "TypeError: C is undefined". – Paul Lammertsma May 15 '14 at 7:14
  • 1
    @ShadowWizard I got "Uncaught TypeError: Cannot read property 'flagSubmitting' of undefined " on SO. Try flagging stackoverflow.com/a/23667897/1402846 – Pang May 15 '14 at 7:17
  • @Pang yeah, I tried from the close review where it does still work. – Shadow The Dragon Wizard May 15 '14 at 7:17
  • Came here just to report this, but looks like you beat me too it – psubsee2003 May 15 '14 at 7:19
  • @psubsee2003 well actually credit goes to Mystical who was the first to notice and report, otherwise I would have missed it until trying to flag or close. :) – Shadow The Dragon Wizard May 15 '14 at 7:20
  • I've tried on SO and MSO as well, and had the same problem. – psubsee2003 May 15 '14 at 7:22
  • 5
    Fix is being pushed for this right now. – Tim Post May 15 '14 at 7:22
  • Thanks @Tim! :) – Shadow The Dragon Wizard May 15 '14 at 7:24
  • Did anyone spin the wheel of blame? – psubsee2003 May 15 '14 at 7:26
  • @TimPost as a moderator, perhaps you can close this question immediately? – Baby May 15 '14 at 7:34
  • 1
    @ImmerAllein Mods go through the same system except that their votes are binding. So if we can't flag it, they can't either. A push by a dev is needed. – Mysticial May 15 '14 at 7:37
10

There's a bit of plumbing going on ...

enter image description here

Well, this might be a more accurate depiction:

enter image description here

A fix is being has been deployed.

  • 2
    Is this the punishment for the responsible dev? Looks cruel, even in your standards! :-D – Shadow The Dragon Wizard May 15 '14 at 7:35
  • 1
    I always wonder, where do you get all those relevant images from? – DroidDev May 15 '14 at 7:36
  • 3
    @DroidDev I've got probably thousands of images of things that are 'overly complicated' - many of them with plumbing / cabling depicted because that's one of the most common software engineering analogies. I've just been collecting them for years. And, I'm a big Stooges fan. – Tim Post May 15 '14 at 7:38
  • 1
    @ShadowWizard Could be worse – Gilles May 15 '14 at 7:43
  • @TimPost - I did a bit more digging in and found out that there was another bug appearing on the load of every page. I happened to mention it in my post. Just wanted to know if this bug is being fixed too? Or is that something totally unrelated to this? Btw, Curly was my favorite among them :) – SudoRahul May 15 '14 at 7:43
  • @DroidDev I suspect he's stealing images from Bart, he also seems to have endless repository. ;) – Shadow The Dragon Wizard May 15 '14 at 7:43
  • If you have ever seen ben 10 you should be knowing, plumbers used to save world from aliens. ;) – DroidDev May 15 '14 at 7:46
  • @ShadowWizard In that case, bart can sue him for using his images for rep harvesting. ;) :) – DroidDev May 15 '14 at 7:47
  • If someone actually tried to sue me for rep I'd probably start throwing my badges at them, with the pins open. – Tim Post May 15 '14 at 7:50
  • I thought mods could call unicorns in these kind of fights. ^) – DroidDev May 15 '14 at 7:51
  • 1
    @DroidDev Huh? Mods are unicorns in these kinds of fights. – Tim Post May 15 '14 at 7:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .