I am unable to log on to the official Stack Exchange Android app. I receive the following error as soon as I try "Log in using Google". (This is the same Gmail account I use for Stack Exchange.)

'key' is not valid for passed 'access_token', token not found.


On my Android Device (Galaxy S4 4.4.2), I have two Google accounts – will this have an effect, or am I missing a step in order to log on with a Google account using the Stack Exchange Android app?

  • I am facing the same issue on a Moto X with 4.4.2. I have only a single google account set up on the device.
    – Ajoy
    Commented Jun 11, 2014 at 19:00

4 Answers 4


This will be fixed in the 1.0.84.

The default behavior when making an API request from the app is to include the access token associated with the session. Since the request had a bad access token, it was rejected even though the purpose of the request was to get a new access token. We had the exact same issue a while back on iOS.

The solution is just to flag the login methods not to pass the old auth token when performing login operations. I'm also making sure we clear it from memory on log out.

  • You moved to the android app team? Commented Mar 1, 2016 at 19:50
  • 2
    @ShadowWizard You're forever the optimist. I'm really just avoiding work I should be doing on iOS. Commented Mar 1, 2016 at 19:55
  • <sad>oh well, back to working on the iOS app.</sad> :D Commented Mar 1, 2016 at 19:59

I had the same problem when I tried logging in for the first time with a StackExchange account.

After thinking I had the password wrong (after numerous tries), I tried logging out and back in to SO on my computer with the same password (which worked, meaning I had the password right), and after that logging in via the StackExchange app worked.

I figure maybe because my account is several years old, maybe if a token was created at account creation (or last login) time, that the format of it is no longer valid, and a re-log in updated the token.

So perhaps try logging out/in on your computer, and seeing if that fixes the problem.


This accured to me after having not used the app for a while (probably a month or more), being logged in using Stack Exchange. Tapping logout in settings did nothing, but after cleaning app data every thing woks as expected and I'm able to login again.

I guess the oauth refresh token expired.. Or something along those lines. However just logging out didn't seem to clean them, which probably is what should happen.

OnePlus one App Version 1.0.78


I had the same issue, try to reinstall the app and it will work again.

  • 2
    Reinstalling and then logging in with the google id, instead of the stack overflow id, worked for me as well. Strange.
    – Ajoy
    Commented Jul 12, 2014 at 17:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .