16

Very recently (May 2014) it was possible to paste images directly from the clipboard into the SE "add an image" dialog. I'm not sure when this feature was added but it was probably after this question in Feb 2014 asking for it and before this answer I posted in April 2014 which mentions it, so probably around March.

It seems to have gone - it no longer works for me on Chrome or Firefox, on here and at least two other sites (stackoverflow and graphicdesign.SE). Has it been dropped?

Here's how the image dialog looked in April:

enter image description here

...and now (note no more "or paste"):

enter image description here

It's a shame if it has as it made adding screenshots much easier. There are questions I answered that I probably wouldn't have answered if doing so would have required saving images then uploading them then deleting them rather than pasting straight in (sounds silly but for quick "how to do X" answers is near doubles the answering time, and I don't like peppering my work desktop with non-work files when taking a 5 minute SE break between tasks).

Based on comments so far my suspicion is that this is a bug and that something about latest browser versions makes SE think they don't support direct paste of images, when actually they do.

On Mac, Lion 10.7.5, UK IP address, browser versions tested are:

  • Chrome: 35.0.1916.114 - no "or paste" text, pasting on SE doesn't work, but pasting into imgur works
  • Firefox: 29.0.1 - no "or paste" text, pasting on SE doesn't work, but pasting into imgur works
  • Safari: 6.1.2 (7537.74.9) - bizarrely, has "or paste" text, but pasting doesn't work here or on imgur. I've never tried SE in Safari before so I don't know if this is new or normal.
  • For me it still says (or paste or drag-and-drop). Maybe an incompatibility with whichever browser you're running? – mhlester May 30 '14 at 15:44
  • @mhlester Strange, I tried both Firefox and Chrome (both up to date), and both worked very recently (this week even?). Just checked and it's both questions and answers. Which browser are you using? – user568458 May 30 '14 at 15:46
  • 2
    Oh no! I went to check my Chrome version number, noticed I needed to update, and after restarting the text now just says (or drag-and-drop) – mhlester May 30 '14 at 15:52
  • 1
    @mhlester Nooooooo!! Sorry! We must spread the word before more people suffer... someone pull the plug on Google's upgrade servers! – user568458 May 30 '14 at 16:02
  • I noticed that this stopped working around the time I moved to OS X Mavericks. I blamed it on Skitch and the retina-res images.. – Martijn Pieters May 30 '14 at 16:31
  • Related: meta.stackoverflow.com/questions/255854/… – Oded May 30 '14 at 16:58
  • @mhlester If "Please halp! This... really sucks :(", offer 500 rep bounty. If you don't want, ask me, I'll offer. :) – nicael Jun 6 '14 at 19:59
  • @nicael 50 gets just about as much publicity as 500 – mhlester Jun 6 '14 at 20:12
  • @mhlester No, it is tested by me. – nicael Jun 6 '14 at 20:26
  • 1
    @nicael and I fear you're proved wrong by Oded. ;) – ShaWiz Jun 11 '14 at 13:50
  • @ShadowWizard What do you mean?.. – nicael Jun 11 '14 at 13:54
  • @nicael Oded fixed the bug even though it's "only" 50 rep bounty and not 500. :) – ShaWiz Jun 11 '14 at 14:00
  • @ShadowWizard With 500 rep bounty Oded would fix this bug faster )) – nicael Jun 11 '14 at 14:01
  • @nicael guess we'll never know now! – ShaWiz Jun 11 '14 at 14:01
  • 1
    I have created an userscript that allows pasting the images directly in the textarea. It's lighter than normal GUI approach and works in Firefox, Chrome and Opera. – Tomáš Zato Dec 1 '14 at 14:03
8
+50

Paste is working again in webkit browsers.

The popup doesn't say so, but it does.

  • 2
    That's a good step forward, but still no Firefox (as of latest version 30.0). Status-completed might be a bit premature. – user568458 Jun 11 '14 at 12:45
  • 1
    @user568458 - image paste on FF never worked. It is supported on webkit browsers only, at the moment. – Oded Jun 11 '14 at 12:54
  • Let's see :D – ShaWiz Jun 11 '14 at 13:53
  • 1
    @ShadowWizard whut? – user568458 Jun 11 '14 at 13:55
  • @user568458 I pasted this image to test if working. It works. It says "Thank you" in Hebrew. – ShaWiz Jun 11 '14 at 13:56
  • @user568458 - He is saying thanks in our secret language, Israeli to Israeli ;) – Oded Jun 11 '14 at 13:56
  • True, I was using this feature a lot and was really sad to see it broken, so now really happy to see it back, @user568458 :) – ShaWiz Jun 11 '14 at 13:59
  • 1
    Trying my luck with a totally different bug, any idea what happened to drafts, @Oded? According to comments here, they're not being saved for a full week for long long time now. I've just confirmed by having two question drafts two days ago (on two different sites of course), didn't touch anything, and now they're both gone. Bug report is here: meta.stackexchange.com/questions/233732/… – ShaWiz Jun 11 '14 at 14:17
  • @ShadowWizard - first I've heard of it. – Oded Jun 11 '14 at 14:36
  • 1
    @Oded that's why I'm here! :-) – ShaWiz Jun 11 '14 at 14:37
  • @ShadowWizard - will ask around. Wouldn't be surprised if this is related to the DC move and normal services should resume going forward. – Oded Jun 11 '14 at 14:38
  • 1
    That was my first impression as well but then I noticed this comment, made 8 months ago, so looks like it's broken for long time. Unless there was a DC move back then as well? It's one of those things not really used widely so it might go unnoticed. – ShaWiz Jun 11 '14 at 14:40
  • It is possible, @Sha - given a few days need to go past in order to test the feature... – Oded Jun 11 '14 at 14:44
  • @Oded for us mortals it's true, but you can just check the source or REDIS itself to see what's going on in there. No? – ShaWiz Jun 11 '14 at 14:45
  • @ShadowWizard - I normally just checksum the bytes on the wire, as the whiz along – Oded Jun 11 '14 at 14:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .