5

Here are the steps to reproduce this problem:

  1. Be on a device where I am not logged-in to a meta site.
  2. Go to the main *.stackexchange.com site - Everything seems to work fine.
  3. Go to the meta.*.stackexchange.com site and click log in in the title bar - Page just refreshes without logging in. WTF?

Here is the workaround I have found to work:

  1. Go to main *.stackexchange.com site and click on help=>meta
  2. Click through the warning about the bad SSL certificate.
  3. Log-in works.

I'm not fussy about whether my connection to SE is encrypted. However, I do care that this problem created a barrier to my participation in meta.*.stackexchange.com. I cared and knew enough to poke at this thing for five minutes and find a workaround so I could vote on a meta item that I cared about. I doubt, however, that this is the case for most users. It concerns me that participation in meta is being filtered by a technical problem.

I use chrome as my browser, and my google account to authenticate. The problem exists on both Travel and English se.com on both a Windows 7 and 8.1 machine.


This question seems similar. However, the symptoms are different in two ways: In my case no login page is ever presented, and I'm not using OpenID.

  • 3
    HTTPS is still work in progress. It is still not officially fully supported. Valid certificates on all child meta sites is one of the outstanding issues. – Oded Jun 14 '14 at 17:51
  • @oded I understand that. The issue is that I can't even log in to meta unless I know this hacky workaround that happens to use broken HTTPS. I'm not asking for HTTPS to get fixed, I'm asking for the broken HTTP login to get fixed. – alx9r Jun 14 '14 at 19:18
  • @alx9r You don't login to a meta site. You login to the main site. – hichris123 Jun 15 '14 at 0:28
  • @hichris123 Are you saying that if I am logged in to english.stackexchange.com then I should automatically be logged into meta.english.stackexchange when I browse there? – alx9r Jun 15 '14 at 16:19
  • @alx9r Yup, that's what should happen. – hichris123 Jun 15 '14 at 16:24
  • @hichris123 That's not happening for me :( I just logged into the main sites on diy, travel, and english. Then I keyed in the URL for their meta sites. In all cases, I was not logged in to the meta site, and clicking login just refreshed the page without logging me in. – alx9r Jun 15 '14 at 16:33
  • 1
    @alx9r Are you running any browser extensions like HTTP Everywhere? That might be interfering with how things are supposed to work here. hichris123 is right - you don't log into meta sites separately. That's taken care of when you log into the main site. – Adam Lear Jun 16 '14 at 20:25
  • @AnnaLear That seems to be the culprit. – alx9r Jun 16 '14 at 21:55
  • Hmmm. I noted that stack exchange was listed twice in my HTTPS everywhere rules, with green checkmarks. Clicked on each, and now they are listed with red Xx. But the problem is not fixed. – WGroleau Oct 9 '15 at 17:30
  • Well, now I see that the "create account" now gives me the "create and link" screen instead of the "what username do you want screen" But I still can't do Meta. – WGroleau Oct 9 '15 at 17:40
4

As per Anna Lear's suggestion, this seems to be an issue only when using the HTTPS Everywhere extension. With the extension disabled I am automatically logged in to meta.*.stackexchange.com when I am already logged in to *.stackexchange.com.

  • Strangely, even with HTTPS Everywhere disabled, the "log in" button on meta.vi doesn't seem to work for me. (I'm not sure why meta.vi is the only place I've experienced this problem.) – Kyle Strand Feb 25 '15 at 20:14
  • 1
    Glad to know about these two work-arounds, but by the time I found and read them, I had forgotten what I was going to post! – WGroleau Oct 9 '15 at 17:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .