4

So I tried to get into a new site currently in private beta but I've made a mess of it. According to this it should have been straight forward. I followed the links from Area51 and filled in my usual OpenID. My OpenID provider (Google) returned an error and refused to be helpful citing I was trying to login to something that did not exist.

I then tried using an SE login, which apparently I already had but don't use so of course I had to reset the password. That done I came back to login to the private beta and sure enough, I was in.

The new problem is my SE login does not appear to be associated with my other account. I tried adding it under "my logins", and it appears to work but the association does not happen (when viewed from either side). This leaves me with an orphan account on a private beta that I can't seem to join to my main persona.

Why was OpenID not giving me any love and how do I get it back?

8

Google are deprecating their support for OpenId in favor of OAuth 2.0.

As part of that, they no longer accept new domain names into their OpenId provider - that's why a beta site, which has a new domain name doesn't work with Google OpenId.

This is a recent development, which caught us by surprise, while trying to launch a new beta site.

We are still testing out a transition of Google logins to OAuth 2.0, which has been deployed to a few sites. Once we are happy that it is working well it will be deployed across the board.

This is enabled on all sites currently in private beta, but I just saw one of the metas was missed - you should be OK to log in now.

  • 1
    Ouch, that is news to me too (and I should have been aware of such a deprecation). Thanks for the explanation. Shockingly, searching meta here does not seem to turn up anything useful on merging orphaned accounts. Is my search foo off today or is there somewhere you can point me? – Caleb Jun 19 '14 at 12:49
  • @Caleb - outside of this? – Oded Jun 19 '14 at 12:51
  • No, pretty much like that. Except it won't let me submit the form with ID's from different sites and I cannot login to MSE with the new orphan identity and I cannot login to the private beta with the old one! – Caleb Jun 19 '14 at 13:07
  • Now I managed to get both logins going on a single site (I used ScFi) but it even though I can login to both accounts it won't let me edit one of them (to do the "merge keep" thing) citing another account of the same email. Nice catch 22. – Caleb Jun 19 '14 at 13:09
  • @Caleb Got links to both profiles? It's an easy fix. – Tim Post Jun 19 '14 at 13:59
  • @TimPost master and orphan 1 and orphan 2. I think both orphans are in the same orphanage, but I've lost track of which way is up over here! – Caleb Jun 19 '14 at 14:06
  • @Caleb I think I've got you all sorted out now, have a look and let me know if I missed anything. – Tim Post Jun 19 '14 at 15:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .