36

I just got a badge on Pets.SE, which is super cool! Except, well, because I am bad with many non-English languages, I am not entirely sure which badge it is.

enter image description here

I am guessing that might be Portuguese? Any reason this is showing up in my notifications like this?

  • 15
    So the bug is that the notification should have been in Klingon, right? – Doorknob Jun 26 '14 at 3:24
  • 6
    +1 for hand-drawn circles. – nicael Jun 26 '14 at 6:23
  • As for what badge it is, your profile says that "Nice Question" was the last badge, and that makes sense; I can't read the text either, but it does look like that question in the notification went from +9 to +10 right around when you posted this question. – Dennis Meng Jun 26 '14 at 6:31
  • 1
    For some reason, it's taking the badge data from pt.stackoverflow.com/help/badges/20/nice-question (so it's in Português) – Shadow The Curly Braced Wizard Jun 26 '14 at 6:42
  • 2
    Folks at Stack Overflow em Português are so excited that the question always pops "when we'll have other stack sites in Portuguese", well, looks like sooner rather than later :-) – brasofilo Jun 26 '14 at 7:43
  • 6
    @ShadowWizard: Somebody at SE thought "pt" was short for "pets"? ;) – Ilmari Karonen Jun 29 '14 at 18:23
  • @IlmariKaronen you know, it might be true! – Shadow The Curly Braced Wizard Jun 29 '14 at 19:16
  • Can you repro? I see the English version in your list at the moment. – Sklivvz Jul 4 '14 at 15:40
  • It disappeared, but other people have reported the same thing. – Ash Jul 4 '14 at 16:47
12

This bug was a race condition in our badge name/description caches. These strings are cached per-site, on each web server.

What normally happens is, a badge is viewed on its owning site, so the language rendering matches, e.g. English badge names on English sites.

However, in this particular case, a http://pt.stackoverflow.com user viewed their topbar/achievements on the Portuguese site, and they had a badge on http://pets.stackexchange.com ! This incorrectly cached Portuguese badge names for an English site (but only on one web server).

The fix is to explicitly pass in the proper locale when rendering badges.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .