7

On various meta sites, including Arqade Meta, I cannot login to my account.

I use a Stack Exchange Account and am trying this on Google Chrome 35 with no extensions enabled and third party cookies enabled. I've tried it with Firefox and it worked, and I can use the iOS app. I also tried using Chrome's Incognito mode, with the same outcome.

I have posted to the Arqade Meta site before using the iOS app, so I do have a meta profile.

I will log in to the normal Arqade account no problem, but when I go to the meta site I won't be logged in anymore, and if I click the login link the page just reloads. If I click the "Ask Question" button I get a redirect loop error.

According to Chrome Developer Tools, the website returns a 302: Found response for the https://gaming.stackexchange.com/users/login?returnurl request, and includes these cookies:

gaminguser=t=[redacted]&s=[redacted]; domain=.gaming.stackexchange.com; expires=Thu, 08-Jan-2015 22:49:59 GMT; path=/; HttpOnly
  • sanity-check: clear your cookies (or use Chrome's incognito mode) & log in fresh, see if it still happens. – Shog9 Jul 9 '14 at 1:03
  • I just tried it in Chrome's incognito mode and it still occurred. Signed in on Arqade, wasn't signed in on meta, nothing happens when I click login. – ecnepsnai Jul 9 '14 at 5:33
  • Are you using HTTPS for accessing the site itself? That might cause problems. – nyuszika7h Jul 9 '14 at 12:04
  • @nyuszika7h When I tried going to the meta site on https, I got this certificate warning in Chrome Screenshot If I click Preceed Anyways, I am logged in. So yes, it appears to be because of HTTPS. – ecnepsnai Jul 9 '14 at 22:00
  • @ecnepsnai that is worthy of an answer, can you please add an answer explaining what happened? – Shadow The Coffee Wizard Oct 19 '14 at 8:03
2

I had this problem today, and the comments here helped me figure out how to work around it. The exact workaround that solved it for me was:

On the non-meta page, click "Try" or "Help" in the top-right. Click the "Meta" item in this dropdown menu. If I access a meta SE any other way, then it doesn't see my account, Sign Up sends me to the non-meta site, Log In doesn't do anything at all, and Ask Question enters a redirect loop, making the meta essentially read-only.

Edit: Also, I have to redo this every few minutes =(

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .