2

There is some character escaping problem with this post.

Update:

There is a minor editor problem

  • Edit text: Code\nCode2
  • Mark as code
  • Insert line between Code and Code2: Code\n x \nCode2

Result: Code asd Code2

Should be: Code\n x \nCode2

Original sample:

<project>
  <build>
      <plugin>
            <groupId>org.codehaus.mojo</groupId>
            <artifactId>build-helper-maven-plugin</artifactId>
            <version>1.4</version>
            <executions>
                <execution>
                  <id>add-source</id>
                  <phase>generate-sources</phase>
                  <goals> <goal>add-source</goal> </goals>
                  <configuration>
                      <sources>
                        <source>${eclipse.generated.src}</source>
                      </sources>
                    </configuration>
              </execution>
            </executions>
          </plugin>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-eclipse-plugin</artifactId>
        <configuration>
          <additionalConfig>
            <file> <name>.factorypath</name>
            <content> <![CDATA[

]]> .settings/org.eclipse.jdt.apt.core.prefs

3

2 Answers 2

5

Code must be indented 4 spaces.

See: https://stackoverflow.com/editing-help

or, click the little [?] icon above the editor

or, when editing, click the "full reference >>" link conveniently provided on the right sidebar under "formatting reference"

1
  • I tried it again and it works. It's a bit hard to find formatting problems with invisible characters. Sep 26, 2009 at 10:41
2
            <content> <![CDATA[

You have not indented the part between these lines of the code with the requisite four (4) leading spaces. Is that intentional?

            ]]>   </content>
3
  • No. I think I've pasted it into the form and formatted it using the editor buttons. Maybe the editor has a bug and/or the formatting. Sep 26, 2009 at 10:33
  • 2
    I can't repro that. I paste in your sample, press CTRL+K and it indents everything 4 chars. Sep 26, 2009 at 10:39
  • 1
    Now I know what went wrong. If you edit a region that is marked as code and add a new line this line is not indented. Sep 26, 2009 at 10:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .