0

This question already has an answer here:

I went to preferences, but I didn't see any option to make my email private. I did a search on this site regarding this query, but I was not satisfied with the answer. It seems only moderators can view my email, but there should be an option to make my email public if in case it is private (I should be able to toggle between public and private). But there is no such option, so how do I make sure that my email is private?

Also I don't receive any email in my Gmail inbox if there are any unread messages at Stack Overflow.

marked as duplicate by Martijn Pieters, Shadow The Dragon Wizard, rene, ProgramFOX, user213963 Jul 20 '14 at 18:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Your email is private. If you want it public you'd have to put it in the About Me section. – Martijn Pieters Jul 20 '14 at 12:03
  • There is no option to make it public or private. – Martijn Pieters Jul 20 '14 at 12:03
  • 1
    Please do not ask multiple things in one question. Start a new question regarding the missing email. – Shadow The Dragon Wizard Jul 20 '14 at 12:10
5

Email and real name are mostly private, but if you want it to be public you can place it in the "about me" section on your profile and you're welcome to put something like "I do C# contract work, contact me at john.doe@example.com for a quote".

Otherwise only SE staff and moderators at the sites you're registered on can see it. If it worries you they're going to send you spam (never happens BTW) you can always register using a throwaway e-mail address.

I receive notifications / newsletters just fine to my Gmail account, but under your account preferences the minimum time for unread inbox messages is three hours. Maybe you are checking them more often on-site or don't have that set?

Not the answer you're looking for? Browse other questions tagged .