4

This seems to be new since the comment link was split into two links.

I tend to leave my tabs open a long time, so I often get updates while the page is open. One in particular is when new comments are posted on the question/answer. When this happens, the link is updated to the number of new comments.

However, the javascript events don't seem to be reset correctly - when I click on one, I'm sent to the top of the page due to the href="#" (and the comments don't load). Refreshing the page temporarily fixes it, until a new update comes in.

EDIT:

  • It doesn't work in Firefox, but works in Chromium.
  • No errors.
  • When clicking, there's 2 POST to /gps/event that return 204 No Content
  • I am logged in on Chromium but not on Firefox (currently at work, will have to switch accounts). It seems to be a logged-out thing, it's working on Firefox and Chromium now that I'm logged in on both.

EDIT2:

Confirmed by making a comment with a logged-in Firefox and watching from a logged-out Chromium; it jumped to the top of the page without loading anything.

An error does occasionally appear in the Chromium console on page load, but only if I'm logged out. No new errors appear when clicking on the link:

Uncaught SecurityError: Failed to read the 'localStorage' property from 'Window': Access is denied for this document. 
  • What browser and OS are you using? Do you get any JavaScript errors? Any network errors? – Oded Jul 28 '14 at 17:39
  • @Oded Added some info – Izkata Jul 28 '14 at 18:04
  • It seems to not be updating at all now, but that might be just because I was the only new comment – Izkata Jul 28 '14 at 18:12
  • @Izk What version of Firefox? What OS? – ShaWiz Jul 28 '14 at 18:45
  • @ShadowWizard So it works now, I was able to show your comment in Chromium and Firefox now that I'm logged in in both (FF 30 on Ubuntu 12.04) – Izkata Jul 28 '14 at 19:05
  • I get this intermittently, FF 31 on Windows 8. – Rawling Aug 5 '14 at 14:47
  • I get this all the time, in fact often enough that it is an annoyance, and have been getting it ever since the comment update. I use Opera, which is basically Chrome. – ntoskrnl Oct 3 '14 at 16:16
  • @ntoskrnl I don't know why your title edit was rejected (it was based on the content after all); I put the "unregistered users" part into the title like you tried. – Izkata Oct 3 '14 at 17:15
  • Thanks. Also, this issue isn't specific to Firefox. Oh, and I also posted a duplicate question here: meta.stackexchange.com/questions/240485/… :) It will probably be closed but will hopefully draw attention to the problem. – ntoskrnl Oct 3 '14 at 17:19

You must log in to answer this question.

Browse other questions tagged .