4

I recently received a message on careers.stackoverflow.com. I am not interested in contents of the message so I decided to ignore it. I've since had two follow up emails from do-not-reply@ reminding me that I've received a message. How do I stop receiving these 'reminders'?

The message UI I see is this:

careers "not interested" UI

This UI is very surprising to me for the following reasons:

  1. I need to select a follow up on why I'm not interested. I understand that this is valuable information for Careers but I have no way to opt out. (Remember that I also can not find a way to unsubscribe from the 'reminder' emails).

  2. This particular message was sent by a recruiter. There is no option to "block messages from recruiters". I can only block this particular 'employer'.

  3. There is no submit button for the "not interested" option! I can not actually submit my choice. If the submit button is the "Send Message" button, then what happens with the message? (I don't have a message for him aside from "go away") I don't want to notify this 'employer' of anything, I don't even want him to know that I've read his message (does he know?). The UI does a very poor job at explaining what is happening.

What I want is to simply ignore this message because I am not interested. So short of blacklisting careers.stackoverflow.com, what are my options?

Note: "mark as read" does not stop the 'reminders'.

Minor bug: clicking on "Block this employer" doesn't actually check the associated checkbox. I suspect this might be intended (because all the other labels work just fine), like one of those "no I don't want to install your Toolbar" where they make it as hard as possible to opt-out. If it is indeed intended then I find this very disrespectful.

  • Also, can you let me know what OS/Broswer your using? I can't repro the check box bug. – Juice Aug 15 '14 at 17:44
  • Also, what happens when you check the Block This Employer check box? – Cullub Aug 15 '14 at 21:25
  • @Juice Chrome 36 – Halcyon Aug 18 '14 at 12:25
  • @cullub the checkbox gets checked, nothing else changes (no new UI pops up). – Halcyon Aug 18 '14 at 12:26
5

If you don't want to get notifications from us, then you need to log into your account and disable your profile from being included in the candidate database.

enter image description here

After which you'll never get an e-mail from us again except for very infrequent reminders that you have a profile with us, which can also be disabled by clicking the unsubscribe link at the bottom of the e-mail.

Now, to answer your questions.

  1. Yes, this is important information for us. It's a also a signal to the system. For instance, maybe you got a job and forgot to update your Careers profile. Selecting "I'm not interested in receiving messages at this time" will take you out of the system.
  2. In our system there's no differentiation between an employer and a recruiter. We allow recruiters as long as they're disclosing the position and company they're recruiting for. Clicking "block this employer" will block that user from ever contacting you again. If it was a truly heinous message, please forward it to careers@stackoverflow.com and we'll refund their money and ban them from the system.
  3. That is really a UI issue on our end. Our end game for you is to select one of the options and then simply send a blank message (or you can write a polite message declining the interest) and the employer will just receive a "not interested" notice. This definitely needs some looking at.

I'll also look into that bug you pointed out. It certainly should be checked when you click it.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .