8

At the bottom of every closed question, there's text that says:

If this question can be reworded to fit the rules in the help center, please edit the question or leave a comment.

The words "leave a comment" are styled as a link but do not link to anything. The link should have the same effect as clicking the normal "add a comment."

Also, unless we notify close-voters of the comment, the words "leave a comment" should be removed altogether because leaving a comment on its own will not help the question to be re-opened.

0
1

Yep; that was a glitch introduced in some recent tweaks to the comments UI; the link will work correctly in the next deploy.

10
  • Do you know when the next deploy will come? I see this glitch is still happening on Code Review SE.
    – holroy
    Oct 2 '15 at 2:41
  • Or possibly a similar glitch, as the normal "add comment" on a question that is on hold doesn't show, and the link related to comments doesn't work. At least not for me. See codereview.stackexchange.com/q/106045/78136
    – holroy
    Oct 2 '15 at 2:42
  • @holroy can you be very specific (screenshot?) about what link isn't working, so I can track it? Trying anonymously I don't see any, and as myself it all works - but that might be because I have a mod flag.
    – Marc Gravell StaffMod
    Oct 2 '15 at 7:03
  • Here is a link to a screenshot of the given question: s18.postimg.org/w0pkevm5l/FA02_Broken_Comment_Link.png. @200_success meant it should work, although the text indicates it doesn't. But then again, he might have a mod flag as well
    – holroy
    Oct 2 '15 at 8:37
  • @holroy anywere is fine; easiest thing is to click "Add Another Answer", use the image upload tool, but don't save the answer - just post the link as a comment
    – Marc Gravell StaffMod
    Oct 2 '15 at 8:38
  • Thought about that option, but decided to use postimg.org... :-)
    – holroy
    Oct 2 '15 at 8:39
  • @holroy yes, 200_success has a mod flag; I can't see which link it is that isn't working - can you be more specific?
    – Marc Gravell StaffMod
    Oct 2 '15 at 8:39
  • The bottom link: "comments disabled on deleted / locked posts / reviews". It has a hover effect indicating it should work, but text indicating it shouldn't work. Kind of confusing!
    – holroy
    Oct 2 '15 at 8:40
  • I'm sorry if I'm just mistaken and this is by design, but since it has a hover effect I was confused whether this should work or not, of if it is connected to privileges and reputation (outside of the mod flag)
    – holroy
    Oct 2 '15 at 8:43
  • @holroy it is by design that you can't comment; I'm looking to see if we can clarify that (not make it a link, for example)
    – Marc Gravell StaffMod
    Oct 2 '15 at 9:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .