2

I recently realized that everywhere on stackexchange my Gravtar user image isn't showed, nowhere except Area 51.

I'm aware this question exists: Why isn't my Gravatar image updating? But I haven't changed neither my Gravatar picture nor my email for a long time.

The problem seems to be that a wrong hash is used in the request. The request (on any site except Area51) for my image looks like:

https://www.gravatar.com/avatar/b6ff9d5130128e295b4cf69742c0458c?s=128&d=identicon&r=PG&f=1

But b6ff9d5130128e295b4cf69742c0458c isn't the hash of my email! fcb8958be3b2d1c5049f96e900c29b14 would be the correct hash.

Additionally &f=1 is appended to my request, which forces the default randomly image.

In Area51 my Gravatar Image request is:

http://www.gravatar.com/avatar/fcb8958be3b2d1c5049f96e900c29b14?s=128&d=identicon&r=PG

I'm 100% sure I'm using the same email address.

Does anybody knows the reason for this strange request for my Gravatar image?

7
  • Have you tried changing your email address? Aug 25 '14 at 17:38
  • @MartijnPieters You mean I should try to change my email and then change it back again?
    – idmean
    Aug 25 '14 at 17:39
  • Exactly. If that doesn't work, another email address, then back again. Aug 25 '14 at 17:39
  • @MartijnPieters I changed to another address, it showed another Gravatar (again including f=1) when I changed back it showed again my old one, and not my image.
    – idmean
    Aug 25 '14 at 17:41
  • How certain are you that the Area51 address isn't different? Have you tried changing that then changing it back again? Aug 25 '14 at 17:43
  • @MartijnPieters I'm certain my area51 address is the same, I checked that before posting thew question. Additionally if it was a different my image won't show up.
    – idmean
    Aug 25 '14 at 17:45
  • I cannot see what email address you are using on any of your accounts, so I am stepping through basic debugging tests. It might be possible for the field to contain a non-breaking zero-width joiner character, for example, in which case it'll look fine, but not actually be the same value. Aug 25 '14 at 17:47
4

You have your avatar on Q&A sites set to "identicon". Switch it to "Gravatar" by hovering over your profile image on your profile, and you should be all set.

If you want to propagate this change to all your site profiles, go to the full edit page, change the image there, and then hit "Save and Copy Profile to All Stack Exchange Accounts".

4
  • Thanks that solved it. But I've never changed that. I even haven't known that's possible, strange...
    – idmean
    Aug 25 '14 at 17:49
  • But do you know why the request was using a wrong hash?
    – idmean
    Aug 25 '14 at 17:52
  • It's not wrong, it's salted. The point of these identicons is to divorce the hash from the user's email address since it's (now) our default image for folks.
    – Adam Lear StaffMod
    Aug 25 '14 at 17:53
  • Ahh, I understand. Good to hear that privacy is important to stack exchange.
    – idmean
    Aug 25 '14 at 17:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .