3

Is it possible to set a site as default when composing/forking a SEDE query? It always defaults to Stack Overflow and the user is required to change sites before running the query.

My intention is to drive folks from a specific site into a query that runs directly for that site without the need of swapping sites, thus having to provide instructions for people who don't know SEDE.

I've tried researching into existing queries and checked the database schema. Donnow, but looks like the only possibility would be a URL parameter &site=SITE_ID...

I've found the following related questions but there's no hint about this issue:

  • "It always defaults to Stack Overflow" - This isn't quite true, can you explain in a little more detail? You do have to be logged in for it to remember your preference, though. – Tim Stone Aug 25 '14 at 20:59
  • But I agree that there's a more general problem of sites "having" queries (even though they're all the same set of queries), instead of queries having site preferences. – Tim Stone Aug 25 '14 at 21:01
  • If I open a given query the site is set as shown in the snapshot (just added to the question + the intention). . . . But, is it a matter of remembering a preference? @Tim – brasofilo Aug 25 '14 at 21:23
  • 1
    Ah, you just need to have the right site name in the URL. For example, linking the query like this will have it run on WordPress by default. – Tim Stone Aug 25 '14 at 21:29
  • Oh, sweet! What about pt.stackoverflow.com? – brasofilo Aug 25 '14 at 21:33
  • It's just pt in the URL in that case (which isn't exactly correct...hm, but I don't think anything's broken by it) – Tim Stone Aug 25 '14 at 21:39
  • Oh, I swear I tried that but of course I didn't :/ Nice, thanks a bunch! – brasofilo Aug 25 '14 at 21:44
  • Last query: this http://data.stackexchange.com/ubuntumeta and this http://data.stackexchange.com/meta.askubuntu work, but I can't find the URL to Meta.PT.SO... – brasofilo Aug 25 '14 at 22:01
  • Hm, it's ptme, which is definitely wrong. I'll see if that can be fixed. – Tim Stone Aug 25 '14 at 22:03
2

As shown by Tim Stone, it's a matter of adding the site name (*.stackexchange.com) to the URL, like wordpress or pt (pt.stackoverflow.com):

http://data.stackexchange.com/SITE_NAME/query/ID/SLUG

Playing with SEDE and paying attention to the URLs, this doubt is at plain sight: changing sites shows up the desired URL.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .