3

I'm getting the error "Unsupported OAuth version or server" when trying to sign in via Google. What's the deal?

I went to https://earthscience.stackexchange.com/ and wrote a question. Before I submittted it, I clicked on the sign in via google button. It brought me to a page that said "Unsupported OAuth version or server". I tried it again several times with the same effect.

Using Chrome Version 36.0.1985.143 m on windows 8 64 bit

  • If someone gave you a bug report that effectively said "what's the deal with x", what would you tell them? Try to include some more details to help the developers isolate the problem, like steps to reproduce, screen shots, browser version, etc – psubsee2003 Aug 30 '14 at 21:53
  • I would expect them to tell me if its a known problem or not. But you have a reasonable point, i'll add some details – B T Aug 30 '14 at 22:19
  • If it's a known problem, you would be able to search for it. What web browser and which version are you using? – Doorknob Aug 30 '14 at 22:31
  • Weird. The only other report ever made was deleted by a dev few years after being posted. Looks like nothing on Stack Exchange side. – Shadow Wizard Wearing Mask Aug 30 '14 at 22:52
  • @Doorknob Updated the question to have the version ^ – B T Aug 30 '14 at 22:53
  • 1
    Reproduced. Looking into it. – Adam Lear Aug 30 '14 at 23:09
  • 1
    Better hope this is fixed soon, as it's sure to be a great question! ;) (from an Earth Science mod) – hichris123 Aug 30 '14 at 23:10
  • 1
    Fun fact: the details here (specifically, that you clicked "sign up" from the Ask Question page) were quite relevant. :) – Adam Lear Aug 30 '14 at 23:11
  • @hichris123 Already posted it as a guest! earthscience.stackexchange.com/questions/2427/… – B T Aug 30 '14 at 23:18
  • @AnnaLear You know whats stupid? I'm a developer myself, and I would have hated my initial question as a bug report. I'm usually good about that, but I think the fact that this is a stack-overflow-like situation changed the way i decided to write about it. – B T Aug 30 '14 at 23:18
  • @BT Oh, that's your question. Btw, you should have someone merge your accounts when this is fixed (just poke Anna with a non-sharp/pointy stick. ;)) – hichris123 Aug 30 '14 at 23:20
  • @BT your edit is exactly what I was trying to suggest. The bug report is much more complete now. Thanks for taking my feedback. – psubsee2003 Aug 30 '14 at 23:28
  • That's a good idea hichris, @AnnaLear mind obliging when you have a sec? – B T Aug 30 '14 at 23:34
  • @BT Sure thing. Merged. :) – Adam Lear Aug 30 '14 at 23:39
  • @AnnaLear Thanks! – B T Aug 30 '14 at 23:43
3

This will be fixed in the next prod build - likely sometime on Monday. In the meantime, kindly hit "sign up" from the top bar first and then ask your question. :)

The gist of the issue here is that we switched to Google OAuth2 a bit ago since they're phasing out their OpenID support, but we forgot to update one of the views.

| improve this answer | |
  • Ah, i'm surprised you guys have that kind of code duplication, tho maybe I shouldn't be – B T Aug 30 '14 at 23:46
  • 3
    @BT Yeah, I'm with you there. It's on my list to clean this sort of thing up. Next week's theme is "Paying Down Technical Debt". :) – Adam Lear Aug 30 '14 at 23:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .