3

I've seen this couple times already. I visit a site using a link from Google or Stack Exchange itself, I'm not logged in, and yet the "Welcome back, Braiam. You've been logged in." doesn't appear until I go to the main/question page. This doesn't seems like the desirable behavior (in fact I remember that was the behavior). Can we fix, PLOX?

  • 1
    -1 for PHP. SO is coded in glorious C#. – Won't Sep 19 '14 at 15:36
  • @Won't actually is shell script... – Braiam Sep 19 '14 at 15:57
  • 3
    Because SO is written in shell script? Admit it, PHP dev. Admit to your crimes. – Won't Sep 19 '14 at 16:07
  • @Won't you sure? – Braiam Sep 19 '14 at 16:10
  • Hah! A clever ruse! But I see through it! – Won't Sep 19 '14 at 16:13
2

It normally does:

Screenshot

I'm not sure why that doesn't happen for you, but it definitely sounds like a bug. Some things you could check to help us (and the SE staff) diagnose it would be:

  • Which browser(s) does this happen on?
  • Does it still happen even if you disable all browser extensions?
  • Are there any relevant error messages logged to your browser's developer console when you open a question page where the notice should appear?
  • Just to be sure, does the HTML source for such pages include anything like "globalAuthDisabled": true?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .