5

Wanted to give to iOS app a go just now. The App Store says: "must upgrade to 7.1 or later to use this app".

I'm on 7.0.6, not too far, and yes I probably should upgrade.

However, a couple of points:

  • I'm on a rather poor 3G at the moment so upgrade right now isn't quite feasible;

  • I'm wondering, are there really some features in the app which requires 7.1, perhaps it's is just because it was some kind of default setting in the compile targets, but other than that no other strong reason?

  • some people can't upgrade because they need to maintain certain version.

I will upgrade eventually, but you know, might be worth a quick look if requirements could be lowered to 7.0.x. Or even 6.x.

  • Most likely the app relies on a API only available or reliable from 7.1 onwards. – Martijn Pieters Sep 19 '14 at 20:59
  • 1
    Same reasoning explained here, I guess. – Shadow Wizard is Ear For You Sep 19 '14 at 21:01
  • @Shadow Wizard: yep good link. Although to be fair that's about iOS 7 in general (understand why not iOS 6 now). So yeah, that doesn't quite answer the questions although I think any answer to this would be along similar lines, quite likely. – Philip P. Sep 19 '14 at 21:07
  • @KomradeP. I just dropped the target to 7.0 in the alpha channel. Sign up on that question and you'll be able to try it out. – Brian Nickel Sep 22 '14 at 20:48
  • @BrianNickel awesome, have signed up, will give it a go. Should I mark this as answered unless you want to keep this alive? (not sure how this works on meta) – Philip P. Sep 22 '14 at 20:58
2

On why not 7.0

Update No really compelling reason we can figure out. Dropping it to 7.0 in the alpha channel and we'll keep watching it.

I asked Arie and neither of us have a good reason why the app got set to 7.1. (Maybe git can answer that for us.) We'll probably talk about whether or not to move it down to 7.0 on Monday but some factors that would conspire against it are:

  • Xcode 6 doesn't include a 7.0 simulator (just 7.1).
  • We don't have 7.0 phones anymore.
  • Our app has never been tested on 7.0 (all beta testers and existing users are 7.1+).
  • All phones eligible for 7.0 are eligible for 7.1.

These are not the strongest reasons and there are ways to work around each but they are things I consider.

On why not 6

There are three big things, at least in my opinion:

  • It would be a nightmare. The visual presentation differences between 7 and 6 are not trivial and there are several features of 7 we use to make the app better. It would also greatly expand our testing surface.

  • 6 market share is small and getting smaller. It is still on maybe 6% of phones but the app is on a tiny sliver of network users' devices. We have a lot of room to grow and right now that means going for the easier wins first (like iPad support).

  • We are still figuring out what we're doing here. The mobile apps are still in their earliest phases. Our biggest focus is around making mobile a great experience that people want to come back to again and again.

  • "We don't have 7.0 phones anymore." Yes that's partially why we need to keep ours at certain versions. Ok I lie a bit, in my particular case I don't need to with this particular device, but yeah in general we have to be super mindful just because of this (we are on consumer market you see). Appreciate this is pretty minor in grand scheme of things though... – Philip P. Sep 19 '14 at 22:21
  • Actually Xcode does have a 7.0 simulator, you just have to download it. – Undo - Reinstate Monica Sep 19 '14 at 22:25
  • @Undo That's weird. I'm using 6.0.1 on Yosemite and it's only giving me an option for 7.1. – Brian Nickel Sep 19 '14 at 22:27
  • @KomradeP. True. I'll be keeping my 4S at 7.1 for the foreseeable future, which is really hard because my new phone doesn't ship until October. The 4S has been a goldmine for proving "Yes, there really is a performance issue in this code." – Brian Nickel Sep 19 '14 at 22:30
  • 1
    I'm still on 7.0, if you ever need to test something. Never upgraded because I'm chronically out of space. :) – Adam Lear Sep 19 '14 at 23:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .