7

The new toolbar for taking action on comments in the Android app is kinda neat. I noticed a bug in it today though. This is in Android version 1.0.49, on a HTC One running Android 4.4.3.

You can click these screenshots for a larger view.

The bug is pretty simple. I can tap a comment (such as this one):

SevenSidedDie's comment saying "Unusually-topical network question noticed in the sidebar: How close can you get to lava before burning?"

If I then follow a link (such as the one in that comment), the toolbar will remain active for that comment.

We'll now see the new question...

If I try to tap upvote, the app will give me a nonsensical error.

"Comments on deleted questions cannot be upvoted."

If I try to leave a comment reply, it will use the names of the authors of the comment and the question correctly, but the comment will disappear into the void... and turn up somewhere completely different. As illustrated here:

writing a comment reply... posting successfully no errors at all

As you can see, it appears to get submitted perfectly fine, and the app doesn't complain at all. But that comment didn't show up on either the first question or the second, and I have accounts on both sites. I haven't deleted the comment. You may notice, however, the RPG.SE question I was replying to had a post ID of #48239... so it turned up on Physics.SE's post #48239. (Thanks to Andrew T. for finding this!)

Since I've upvoted that comment successfully now, though (through normal means), I can't flag it to see what'll happen there. (I've made a feature request on that here.)

  • 1
    As I don't have an account on RPG.SE, editing and replying this comment fails me: "The account associated with the access_token does not have a user on the site.", and the app didn't ask me to join the site instead. Update: when I access that link normally from the app, it still didn't ask me to join the site when I tried to comment. Might open a new bug report soon. – Meta Andrew T. Sep 23 '14 at 3:56
  • Yup, your comment was posted successfully on this post – Meta Andrew T. Sep 23 '14 at 4:10
  • @AndrewT. Nice snooping! I've added mention of that. – doppelgreener Sep 23 '14 at 4:15
4

This was totally my bad. I set up a nice elegant way of hiding that comment interaction UI when leaving the view but I forgot to actually call the method.

If this is the only regression from the new single-page-view I'm going to be ecstatic! Look for this to be fixed in an update in the next few days.

4

TL;DR

Based from some little experiments and observations on this post, I conclude that the bug is caused by using the reference from the comment on the target site.

My suggestion is to just reset the toolbar (contextual action mode) to default state when browsing off to other post/site.


Here are the experiments and observations that have been done.

Note: I use my first comment on this question as the reference (Post ID #239803, Comment ID #785712)

  1. Before I joined the target site (RPG.SE), attempting to comment returned

    The account associated with the access_token does not have a user on the site.

    This means that my access_token from original site (MSE) is checked on the target site.

  2. After joining the target site, attempting to post a comment returned

    no post found with this id

    This means that the post ID of the comment (MSE's #239803) is checked on the target site's post ID (RPG's #239803).

  3. Upvoting it returned

    comment not found

    I don't know how to search comment based on its ID, but it seems there's no comment with that ID on the target site.

  4. On the other hand, OP's case is different. Upvoting returned

    Comments on deleted questions cannot be upvoted

    Not sure, but probably because the post with ID #48239 is actually an answer, not a question.

  5. And lastly, a confirmation point when OP tried posting a comment from RPG's #48239 on Physics' #136724, but getting posted on Physics' #48239 instead, as seen on the screenshot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .