3

If Chrome is installed, "Log in using Google" always uses Chrome, even if that option is disabled in the settings. Unlike the Facebook button, it doesn't ask, either.

This is somewhat inconvenient for people who have Chrome installed just for testing and rely on iCloud Keychain or 1Password integration in Safari for passwords.

Version 1.1.0.125

  • Make sure the "Use Chrome" setting in the Stack Exchange app itself is disabled: i.stack.imgur.com/16Pv0.png – Shadow Sep 25 '14 at 22:47
  • I did, and it was. It was a fresh install, too. I think it might be the google-plus-ios-sdk favoring Chrome. – nschum Sep 26 '14 at 7:11
  • If you have iOS 8 maybe it's just one of its many bugs. – Shadow Sep 26 '14 at 20:15
2

You're right in assuming this is google-plus-ios-sdk's doing. Unfortunately the authentication process is a black box. From GPPSignIn.h:

// This class signs the user in with Google. It provides single sign-on
// via the Google+ app (if installed), Chrome for iOS (if installed), or Mobile
// Safari.

The only control we have over it is to disable use of the Google+ app.

If I were bold, I would swizzle -[UIApplication canOpenURL:] and reject Chrome URL's while authenticating but who know what that might break. We're just going to have to accept the fact that Google thinks we're super excited about all of their apps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .