3

I tried to do this again:

Keep track of your rejected edits

but when I follow the link in the accepted answer, I get no CAPTCHA when I click on "I am a Human Being".

screenshot with error

I use Firefox 32 with NoScript and have blocked google.com.

When I enable Google temporarily in NoScript, it works.

Please allow the use of Stack Exchange with Google blocked.

  • 4
    ... reCAPTCHA's are served by Google, so what did you expect? If you block Google, it's going to break. – hichris123 Sep 26 '14 at 10:50
  • 2
    Then There must be an alternative fallback method, or at least a hint, that you need to enable google for this. It took me ages to find out the problem – rubo77 Sep 26 '14 at 11:11
6

I cannot reproduce this issue on a standard PC (not blocking Google). We rely on Google to provide reCAPTCHA and also as a login provider for our sites. If you block Google, reCAPTCHA and login via Google will not work. It thus is a requirement of our websites, to some degree, that Google is not blocked. This is by design.

  • 3
    I will look into adding an error message for this case though, as not showing anything and still letting you click the submit button is fairly confusing. – Tim Stone Sep 26 '14 at 14:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .