4

I recently upgraded my iPad to iOS 8.0.2. I'm running version 1.1.0.124 of the iPad app. Whenever I open the app it tells me to update to 1.1.0.127. I tap update, and opens a certain link in Chrome. I tap install ... and nothing happens. Before upgrading to iOS 8, it would update just fine.

Currently, I have removed the app from my iPad but am unable to re-install it.

28
  • 1
    Try removing the old version first. Sep 29, 2014 at 11:36
  • @ShadowWizard I removed both the iPad and iPhone versions, but it's still not working, so now I don't have any SE app available.
    – Scimonster
    Sep 29, 2014 at 12:06
  • Well, it's not like you could use the old version (it requires to update) but yeah, this is a major issue. Sep 29, 2014 at 12:07
  • 1.1.0.127 is the beta app isn't it? Try installing the "real" app from the App Store, until this bug is fixed. Sep 29, 2014 at 12:08
  • @ShadowWizard I reinstalled the iPhone app from the store, but it's not the iPad one.
    – Scimonster
    Sep 29, 2014 at 12:15
  • Oh, didn't know that. And no app for iPad in the store? Sep 29, 2014 at 12:19
  • No, it's still in beta. meta.stackexchange.com/q/239250/259693
    – Scimonster
    Sep 29, 2014 at 12:22
  • Sorry then, thought the iOS app for iPhone also works on iPad and this one is just with extra features. :( Sep 29, 2014 at 12:23
  • It works, technically, it's just made for much smaller screens.
    – Scimonster
    Sep 29, 2014 at 12:24
  • OK, I tried pinging some devs, hope they'll have a look soon. :) Sep 29, 2014 at 12:28
  • Thanks for helping out. :)
    – Scimonster
    Sep 29, 2014 at 12:31
  • @Scimonster after you tap install, could you go to your home screen and verify whether the app is getting installed? (It looks like iOS won't send you to the homescreen automatically anymore) Sep 29, 2014 at 13:09
  • @ArieLitovsky No, it's not. I checked that thoroughly.
    – Scimonster
    Sep 29, 2014 at 13:11
  • @Scimonster could you try opening the link in Safari and check? You could either disable Chrome from the Setting App -> Stack Exchange -> Disable Chrome. Or you could copy it from the invite e-mail. Chrome is working fine here, so I'm trying to eliminate some causes. Sep 29, 2014 at 13:19
  • @ArieLitovsky Not working from Safari either.
    – Scimonster
    Sep 29, 2014 at 13:25

1 Answer 1

6

It's a bug with iOS 8, enterprise distribution and bundle identifiers.

SE have changed the bundle identifier as discussed in chat in the plist to append .ios8fix and now it appears to work.

I've posted an answer on Apple.SE:

This appears to be a bug with enterprise distribution in iOS 8. If you updated to iOS 8 and had an app with the same bundle identifier installed (i.e. the same app) then you'll be unable to install the app.

A workaround is to change the bundle identifier in the distribution plist. This doesn't require the actual bundle identifier of the app to change, just the distribution plist. Alternatively, you can wait until Apple fixes it.

1
  • changing the plist file and appending .ios8fix does fixes the problem but somehow it is installing older version of the app(i know older cz it is familiar) which starts crashing. and reinstalling again fixes it. Nov 23, 2014 at 15:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .