4

Taken from this answer, I get following completely filled and unscrollable horizontal scrollbar:

enter image description here

I guess it might be due to following css-rule:

.comment-body {
    max-width: 630px;
    overflow: auto;
    overflow-y: hidden;
}

Because when I manually add overflow-x: hidden; with the chrome dev-console, the scrollbar vanishes.

Additionally when I actually scroll the scrollbar the following happens (color inversion extension disabled):

asd

For reference, I am using Chrome Version 37.0.2062.124 m on Windows 7 with a monitor res of 1680x1050

  • Same browser, same OS, no repro. Why is it dark? Good chance whatever theme you got that makes it dark, also breaks some CSS. Try disabling the theme and see. – Shadow The Curly Braced Wizard Oct 1 '14 at 12:02
  • @ShadowWizard disabled the extension, repro remains. – Vogel612's Shadow Oct 1 '14 at 12:03
  • So some kind of dark magic... hopefully others would be able to repro as well. – Shadow The Curly Braced Wizard Oct 1 '14 at 12:05
  • It looks like you're using SOUP, which, as of v1.22, injects the CSS rule you quoted to work around another bug. I'll try to fix it if I can reproduce it. If you find more new bugs, it may be a good idea to check if disabling SOUP fixes them, and, if so, report them directly on the SOUP page rather than here. In any case, thanks for the report! – Ilmari Karonen Oct 5 '14 at 21:24
  • (Alas, I can't reproduce this on my Chromium 37.0.2062.120 / Ubuntu 14.04 (281580), with or without SOUP. I don't have a convenient Windows box at hand to check there; for all I know, it might be font-dependent or something weird like that.) – Ilmari Karonen Oct 5 '14 at 21:33
  • 1
    (Just tossed a status-deferred on there so the SE devs know this isn't their bug.) – Laura Oct 6 '14 at 18:08
  • @Laura Replacing that with status-norepro since, well, it's not our bug. :) – Adam Lear Oct 6 '14 at 18:40
2

I was able to "kill" the bug by disabling SOUP, for now I dropped a comment at the SOUP Page on stackapps

As of now, this is officially acknowledged as a bug in the list of known bugs. Additionally Ilmari has already incorporated a fix into the development branch ;)

  • I'm still not able to reproduce this. :( Anyway, since it's apparently reproducible for you, would you mind testing a few things for me? 1) What is the actual width of the div.comment-body element, and of the span.comment-copy inside it, as shown when you hover the mouse over the tags in the "Elements" tab in developer tools? 2) Does changing the CSS max-width to 629px or 631px in developer tools change anything? 3) What about adding width: 630px to the CSS? Thanks! – Ilmari Karonen Oct 6 '14 at 14:17
  • 1) div.comment-body: 620px, span.comment-copy: 621px. 2) neither changes anything 3) div.comment-body now has 630px width, no more scrollbar. span.comment-copy now has 624px width; – Vogel612's Shadow Oct 6 '14 at 14:23
  • Huh, that's... interesting. What about setting width: 620px, or both that and max-width: 620px? – Ilmari Karonen Oct 6 '14 at 14:46
  • @IlmariKaronen no effect. neither with setting width only nor with setting both.... – Vogel612's Shadow Oct 6 '14 at 14:48
  • Hmm, what about adding padding-right: 2px? – Ilmari Karonen Oct 6 '14 at 15:01
  • @IlmariKaronen that works a charm. div.comment-body is now 620px wide and span.comment-copy 606px. Scrollbar is not there anymore. Thanks for reminding my why I don't like css ;) – Vogel612's Shadow Oct 6 '14 at 15:06
  • 1
    Honestly, I think this is a Chrome bug; there's no good reason why the span.comment-copy should ever be wider than the div.comment.body element, as long as it doesn't exceed the maximum width. Anyway, I've added the padding-right kluge to the SOUP devel branch, and it'll be included in the SOUP v1.24 release (which I plan on making sometime this week). – Ilmari Karonen Oct 6 '14 at 15:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .