6

At first I thought it was my clipboard. Then I thought it was my browser. Now I know there's something going on in the SEDE editor...

Hi, I'm Sam, and I sometimes string together long comma separated lists of user IDs and plug them into our data explorer to identify user engagement patterns and try to figure out how we can tweak features to make SE more awesome than it already is.

But I've noticed that I can't paste more than about 2300 7-digit IDs (and commas) into SEDE at once. I can however link sequences of 2300 IDs into SEDE, so we're not looking at a hard character count limit here. This seems to be an issue with pasting.

I'm told there are certain members of the community who maintain SEDE. Maybe you're out there listening? Any chance we can up the character paste count?

  • Pinged the "members of the community who maintain SEDE" :D – Shadow Wizard Nov 4 '14 at 21:04
  • Maybe you should stop pasting in so many comma-separated items? ;) – Taryn Nov 4 '14 at 21:12
  • I wonder if you disable JavaScript does it work? – Shadow Wizard Nov 4 '14 at 21:12
  • @ShadowWizard that seems to introduce a whole new set of problems =/ – samthebrand Nov 4 '14 at 21:18
  • @SamtheBrand You just like breaking stuff, just admit it. – Taryn Nov 4 '14 at 21:23
  • 1
    Pasting into the editor or as a value to a query parameter? – Tim Stone Nov 4 '14 at 21:23
  • Of course, just want to help Tim debug this (e.g. JS issue or not) – Shadow Wizard Nov 4 '14 at 21:23
  • @TimStone pasting into the editor – samthebrand Nov 4 '14 at 21:24
  • Ah, there we go. Reproed, looking now. – Tim Stone Nov 4 '14 at 21:45
2

Okay, from what I gathered there's some underlying issue in WebKit/Blink where the paste gets truncated en route to the rendered CodeMirror display due to wrapping in the hidden textarea.

It seems at some point CodeMirror changed something to work around this, so upgrading to the latest version appears to fix things, at least for the ~80,000 some character string I tested with. A toast on my desktop as I'm writing this has informed me SuperDalgas has already pulled the change, so fixed just pending a redeploy now.

  • Will check tomorrow. Thanks so much for looking into this Tim. – samthebrand Nov 4 '14 at 23:12
  • Don't thank me too much, I still have to update the authentication process to use OAuth before Google drops the OpenID endpoint. :P – Tim Stone Nov 5 '14 at 3:03
  • Ok, no thanks quite yet! But lemme know when I can. – samthebrand Nov 5 '14 at 19:16
  • Hey, it works! Amazing. Big thanks. – samthebrand Nov 7 '14 at 20:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .