3

While attempting to log into Area 51 to ask a question in one of the proposed sites, I was unable to gain access through any of the OpenID options I tried (Google, Yahoo, Stack Exchange). I keep getting error messages along the lines of "Unable to log in with your OpenID provider:"

Here's a full message, with some data redacted:

Unable to log in with your OpenID provider:

The openid.return_to parameter (http://area51.stackexchange.com/users/authenticate/?s={sid}&dnoa.userSuppliedIdentifier=https://www.google.com/accounts/o8/id)  
does not match the actual URL (https://area51.stackexchange.com/users/authenticate/?s={sid}&dnoa.userSuppliedIdentifier=https://www.google.com/accounts/o8/id&openid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0&openid.mode=id_res&openid.op_endpoint=https%3A%2F%2Fwww.google.com%2Faccounts%2Fo8%2Fud&openid.response_nonce=2014-11-29T21{nonce}&openid.return_to=http%3A%2F%2Farea51.stackexchange.com%2Fusers%2Fauthenticate%2F%3Fs%3D3f7aa21d-7a4a-45a9-a419-a184230224fd%26dnoa.userSuppliedIdentifier%3Dhttps%3A%2F%2Fwww.google.com%2Faccounts%2Fo8%2Fid&openid.assoc_handle=1.AMlYA9Xc1p6ilEXNEWsbdopViz9XWZkZ7VblAC4U4GLzdo-iM9RZCjYleRIYrqHs&openid.signed=op_endpoint%2Cclaimed_id%2Cidentity%2Creturn_to%2Cresponse_nonce%2Cassoc_handle%2Cns.ext1%2Cext1.mode%2Cext1.type.alias4%2Cext1.value.alias4&openid.sig={sig}&openid.identity=https%3A%2F%2Fwww.google.com%2Faccounts%2Fo8%2Fid%3Fid%3DAItOawm9zK_z8vWmGXGzxHoXKnSvSdU16AZqxm4&openid.claimed_id=https%3A%2F%2Fwww.google.com%2Faccounts%2Fo8%2Fid%3Fid%3DAItOawm9zK_z8vWmGXGzxHoXKnSvSdU16AZqxm4&openid.ns.ext1=http%3A%2F%2Fopenid.net%2Fsrv%2Fax%2F1.0&openid.ext1.mode=fetch_response&openid.ext1.type.alias4=http%3A%2F%2Faxschema.org%2Fcontact%2Femail&openid.ext1.value.alias4={my email}%40gmail.com) 
the request was made with.

Is this a fault with Area 51 or my web browser (Tor/Firefox)? (The issue doesn't occur on other SE sites.) How do I get into Area 51 with my existing Yahoo/Gmail/SE account details? Could this be related to "I can't login with stackexchange OpenId when HTTPS Everywhere plugin is active" or "Login and rendering problems with Area 51"?

7
  • I don't think that SE will ever support logins from inside Tor network. Whether Tor is really guilty here? I dunno.
    – yo'
    Nov 29, 2014 at 22:19
  • 1
    Up until about half an hour before posting the question, I haven't had issues with SE through Tor except for the occasional caching issue which causes Firefox to prevent login. Nov 29, 2014 at 22:21
  • 1
    then it's probably not a Tor issue, but the very same issue others have spotted zillions of times (including me couple times) for which the only answer is: take a rest, clean cookies, logout from all SE sessions, ... just do something and it will magically work again. However, abracadabra seems not to be the right something and nobody knows the right something.
    – yo'
    Nov 29, 2014 at 22:24
  • [flippant]Smashing things probably doesn't help, either ...[/flippant] I suppose that if I was a normal human being (whatever those are), I'd probably be out attempting to hit on women or getting a good night's sleep instead of filing bug reports (but software is far more interesting and rewarding) ... Nov 29, 2014 at 22:26
  • I tried what @tohecz suggested (clean cookies, logout from all SE sessions, ... just do something) to no effect. To other browsers it is, then ... Nov 29, 2014 at 22:41
  • 1
    Are you using HTTPSEverywhere? If so, then it is very likely causing issues.
    – Shog9
    Nov 30, 2014 at 6:15
  • 1
    Yes, but it's not causing issues in Chrome (only FF/Tor). Dec 1, 2014 at 10:58

1 Answer 1

-3

This is definitely a Firefox issue. Abandon Firefox and derivatives for accessing SE sites. Chrome/Chromium (in incognito mode, with HTTPs anywhere) doesn't throw up any issues.

2
  • 2
    I use the Tor Browser (Firefox), and to say to abandon what is very likely one of the two most-used browsers in the Stack Exchange network user base, can hardly be acceptable as a solution.
    – user212477
    Jan 10, 2015 at 1:55
  • Well, if you don't like it, feel free to offer an alternate solution. Jan 12, 2015 at 6:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .