1

This question already has an answer here:

An answer of mine includes an URL with a ?, which is not correctly parsed. I think it should be.

Actually, I wanted to include the image that is autogenerated from the URL, to show a point of my answer, this did also not work.

marked as duplicate by ShaWiz, Martijn Pieters, nicael, user259867, rene Dec 1 '14 at 18:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

migrated from meta.stackoverflow.com Dec 1 '14 at 11:39

This question came from our discussion, support, and feature requests site for professional and enthusiast programmers.

5

It is not the question mark that is at issue there. You need to properly quote your URL parameters; it is the backslash and braces that cause the query parameter to be ignored.

Rather than use:

https://latex.codecogs.com/png.latex?\sum^{i%3D\infty}_{i%3D0}x_{i}}

use

https://latex.codecogs.com/png.latex?%5Csum%5E%7Bi%3D%5Cinfty%7D_%7Bi%3D0%7Dx_%7Bi%7D%7D

The backslash, caret and braces are all quoted now, not just the = equals signs.

This is recognised as a proper URL: https://latex.codecogs.com/png.latex?%5Csum%5E%7Bi%3D%5Cinfty%7D_%7Bi%3D0%7Dx_%7Bi%7D%7D

and is usable as an image:

  • Thanks for the answer. I wasn't aware of this. Could the "proper" quoting be implemented in the URL parser? – Habi Dec 1 '14 at 9:40
  • @Habi: no, because then any sentence ending in a URL and a question mark would pull in the rest of the post. That's what proper URL quoting is for, so that URLs can be properly recognised and handled. – Martijn Pieters Dec 1 '14 at 9:41
  • That makes sense. This makes my orginal answer less usable then, since a simple copy-paste link for embedding in a forum was asked for :) – Habi Dec 1 '14 at 9:44
  • @Habi: you need to include a online URL encoding step in that case. – Martijn Pieters Dec 1 '14 at 9:47

Not the answer you're looking for? Browse other questions tagged .