9

I didn't have trouble answering questions in the past, but now I fail the human verification check.

Basically, instead of a CAPTCHA, I can check "I'm not a robot". When I check it, it goes away and I get a spinning circle animation.

I don't seem to be able to do anything afterwards; I waited a few minutes, nothing further happened.

I tried with Firefox and Chrome, with and without my ISP's proxy, but it's all the same.

So, how does one pass the human verification stage? I am pretty sure I am not a robot, but am unable to convince Stack Exchange of that.

  • 3
    Sounds like CDN is blocked on your side, so required JavaScript files fails to load. In Chrome, click F12, go to Network tab, reload, and you'll see what exactly is being blocked. Either some firewall/proxy or your ISP is the culprit. – Shadow Jan 1 '15 at 14:30
  • Anything specifically to watch out for (like a hostname)? Chrome doesn'T seem to report anything as blocked. In firefox I use noscript to block google-analytics, but even completely disabling noscript doesn't help. – Marc Lehmann Jan 1 '15 at 14:38
  • Sort the Network tab by status and hard-refresh (CTRL+F5), do you see anything which is not 200? – Shadow Jan 1 '15 at 15:02
  • Also, here on MSE it doesn't work with CDN, do this on a site where you suffer from the problem you described. – Shadow Jan 1 '15 at 15:03
  • 1
    I get lots of 200s, one 101, and, after checkmarking the captcha checkbox, two https requests to google that seemingly hang (no reply). – Marc Lehmann Jan 1 '15 at 15:53
  • 1
    So those last two requests are most likely the problem... what is the URL of both? – Shadow Jan 1 '15 at 15:53
  • I can't seem to select it or copy it, and its too long tot ype in. They start with google.com/recaptcha/api2/frame?c=.... There are other requests to google.com/js... that succeed, so I don't think there is any filtering (especially not of TLS). – Marc Lehmann Jan 1 '15 at 15:58
  • Right click the line and choose "Open link in new tab", then you can copy the URL from the address bar. :) – Shadow Jan 1 '15 at 15:59
  • First thing I tried, but right click doesn't open a popup. – Marc Lehmann Jan 1 '15 at 16:06
  • 4
    hmm.... no further ideas, sorry, but looks like it's something on your side otherwise we would be getting tons of reports. – Shadow Jan 1 '15 at 16:20
  • Thanks for your help - "but looks like it's something on your side" it only affects stackexchange, and only since it uses the new captcha, but anyway, since stackexchange now blocks me, no answers from me anymore it seems. – Marc Lehmann Jan 1 '15 at 16:55
  • Can you try from a different computer? Maybe even different ISP e.g. friend's computer? I can understand if it's too much to ask, just trying to help you point the exact issue, which most likely can't be resolved by Stack Exchange anyway. – Shadow Jan 1 '15 at 18:40
  • 14
    Yeah, this post is exactly what a robot would say. Nice try. – Jaydles Jan 2 '15 at 16:40
  • A few things I wanted to add - first, Jaydles insinuating that I am dishonest is really evil, shame on you. Second, this question recently earned me the "popular question" tag, which is evidence that maybe the problem isn't so rare after all. And lastly, the occurance of this has been greatly reduced recently, so I can comment/answer again, at least at the moment. – Marc Lehmann Jun 28 '15 at 10:26
  • I definitely don't think that Jaydles is saying that you're being dishonest - I think it's more like "It's the dumb captcha's fault, nice try with making a working Captcha, Google". – JonasCz Jul 9 '16 at 15:25
2

If you are having problems with getting past the "I'm not a robot" Captcha, make sure that your JavaScript is enabled. I had to go into the network to enable mine last night to fix a similar problem viewing my gift cards, as Captcha was needed to view them.

2
  1. On the page where you’ve encountered “I’m not a robot” Recaptcha, look at the element’s code.

  2. Find a link that begins with www.google.com/recaptcha/api2/anchor.

  3. Copy the "k" parameter from that link (after “k=”).

  4. Send a GET-request in this form: http://2captcha.com/in.php?key=YOUR_CAPTCHA_KEY&method=userrecaptcha&googlekey=%googlekey% where where YOUR_CAPTCHA_KEY is your key from https://2captcha.com/setting %googlekey% is the "k" parameter from the previous step

  5. You will receive the response in the form of: OK|Captcha_ID where Captcha_ID - is the id of the captcha in our system

  6. After 5-10 seconds make a request to our server in the following form http://2captcha.com/res.php?key=YOUR_CAPTCHA_KEY&action=get&id=Captcha_ID where YOUR_CAPTCHA_KEY is your key Captcha_ID - is the CAPTCHA’s id from the previous step

    As a response you will receive: OK|%response% where %response% is the answer for passing Recaptcha.

  7. In the element inspector find the line that starts with textarea_id="g-recaptcha-response"

  8. Delete the part "display: none;"

  9. On the initial page with the “I’m not a robot” CAPTCHA now there will appear an input field:

  10. Enter the %response% that you’ve received from our server

  11. Click the "Submit" button

  12. You’ve passed the Recaptcha!

Refer to this link for more details: https://2captcha.com/recaptchav2_eng_instruction

You must log in to answer this question.

protected by Community Dec 6 '16 at 15:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .