8

I'm logged into the main sites for Workplace.SE, Physics.SE, Money.SE, and Space.SE; but show as logged out when I go to any of the meta's for those sites. Attempting to log in again results in the page refreshing with my still being logged out. I am able to visit meta.StackOverflow, and meta.SuperUser. (This is not an exhaustive list.)

This is only happening in Firefox; and I've unsuccessfully tried disabling all my content blockers, restarting the browser, and clearing my cache as suggested in this question; but am still locked out.

On pattern I have noticed: The meta's I can't log into in Firefox are all loading the http site for me; while all the ones that do load are going over https. Those meta's are also not using https when I visit using Chrome; but there I am able to log in anyway.

I tried forcing https on meta.space.SE and got this error in my browser:

The certificate is only valid for the following names: *.stackexchange.com, stackexchange.com, meta.stackexchange.com, stackoverflow.com, *.stackoverflow.com, stackauth.com, sstatic.net, *.sstatic.net, serverfault.com, meta.superuser.com, stackapps.com, openid.stackauth.com, *.meta.stackexchange.com, clc.serverfault.com, meta.serverfault.com, superuser.com (Error code: ssl_error_bad_cert_domain)

6

Apparently this is due to Https Everywhere; when I fully disabled it on StackExchange (previously it was only off for mixed content), I was able to log into the other meta sites. Unlike the person from the other question I wasn't being redirected to the non-functioning https sites automatically; and I hadn't made any changes to settings on my side recently.

As a result I'm wondering if Https Everywhere pushed a bad update to its filter list, if something was just changed here, or if Gremlins are on the prowl.

  • Just FYI - Stack has no Gremlins in its systems, just Unicorns – James Mar 17 '15 at 0:15
  • 1
    I'm still seeing this exact same issue. – David Z Aug 23 '15 at 5:20
  • How ironic that such an issue would still exist in this network. – skullpetrol Aug 23 '15 at 12:07
  • That hit me too... :-/ – wizzwizz4 Jun 19 '18 at 16:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .