5

A user on meta Raspberry Pi Exchange, where I'm a moderator, recently asked this question which seems to indicate a bug.

In brief, the user went to edit a question tagged qtonpi. When the edit was saved, this tag was rejected because "The 'pi' tag is not allowed".

The edit history confirms that it was there until that point, and I've tried adding it back myself to no avail. Below is an image from the original user question.

enter image description here

  • Maybe synonym of a blacklisted tag? – bjb568 Jan 3 '15 at 19:05
  • @bjb568 Anyway to check that? Still doesn't explain the mismatch. – goldilocks Jan 3 '15 at 19:27
  • Those blacklists run off of regex. So perhaps they need to be more specific. It might be looking for "pi" anywhere in the tag name. Does this also happen for other tags that might contain that word? – animuson Jan 3 '15 at 19:43
4

Yeah, that was a bad regex: ^raspberry|pi$ instead of ^(raspberry|pi)$. The difference is subtle but important.

Try again now - should be fixed.

  • Something is weird with the revisions, it says "Post Migrated Away to meta.raspberrypi.stackexchange.com" but it's still here... – Shadow The Curly Braced Wizard Jan 3 '15 at 20:22
  • @ShadowWizard Not weird. I misread this post and missed the link to the original report on their meta, migrated, re-read, reversed the migration. – Adam Lear Jan 3 '15 at 20:23
  • I see. But shouldn't there be a "Migration Rejected" in the answer's revision list as well, to explain why it's still here and not migrated? – Shadow The Curly Braced Wizard Jan 3 '15 at 20:27
  • @ShadowWizard Migration-rejection-related revisions never show up on answers since they aren't migrated. Questions are. I see "migration rejected" on the question (along with a lock/unlock and my reopen). – Adam Lear Jan 3 '15 at 20:28
  • @AnnaLear I think he's saying that on your answer here, there is a Migrated Away revision entry, which looks odd. Is it supposed to be there? – animuson Jan 3 '15 at 20:29
  • But as I said in the very beginning, the "Post Migrated Away" notice does appear in the answer here, that is what caused my initial confusion. – Shadow The Curly Braced Wizard Jan 3 '15 at 20:30
  • @animuson I just clarified my comment, but that's a good question. I've no idea off the top of my head. – Adam Lear Jan 3 '15 at 20:30
  • @ShadowWizard Sorry, thought you were talking about the question. :) I'm really winning at reading comprehension today. – Adam Lear Jan 3 '15 at 20:30
  • No sweat, pretty minor issue anyway. Think it's worth a bug report? – Shadow The Curly Braced Wizard Jan 3 '15 at 20:31
  • 1
    @ShadowWizard Can't hurt if only for tracking purposes, but I'm honestly not sure why it works the way it does, so I can't say right now if it's something that's likely to get fixed or whether it's worth fixing. – Adam Lear Jan 3 '15 at 20:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .