2

Sometimes I find the Hot Questions widget appears hung, stuck or frozen. The Refresh button indicates that I have tapped on it by turning blue but the question doesn't change. So the widget UI itself is not frozen - but some back-end process is.

Even after I press the Refresh button several times, the question remains unchanged. But if I stare at it long enough it may come out of the frozen state and very quickly run through several questions (as per the number of taps I did on the Refresh button when it was frozen).

This is very annoying and I didn't find any quick fix for it. I hope you can find the actual problem why it appears hung, and fix it. I have a feeling it's because the widget is polling for new questions from the network. Or something else.

In case it maybe device related, I use a Samsung GT-I9305 with stock Android 4.3.

  • Do you have several copies of the widget? In such case this was already reported – Shadow The Dragon Wizard Jan 12 '15 at 8:05
  • 1
    @ShadowWizard no, just one. Not related to the linked question. He is able to refresh the last added widget. In my case the one and only widget sometimes doesn't refresh, sometimes does. – ADTC Jan 12 '15 at 8:08
  • Hmm... weird, maybe two different bugs then. – Shadow The Dragon Wizard Jan 12 '15 at 8:09
  • @gnat Not directly related to your links as they are concerning the site's main Hot Questions algorithm (server-side). This issue is concerning Android widget only (client-side). The Refresh button is normally able to cycle through questions when tapped. There's no sticking except when this bug manifests. Thanks for the tag edit BTW. – ADTC Jan 13 '15 at 8:36
  • 1
    @ADTC I was just kidding. This bug resembles (only resembles, it's apparently different) what was is complained about at first link and like an implementation of what was asked for at second one – gnat Jan 13 '15 at 8:38

You must log in to answer this question.

Browse other questions tagged .