11

My current app version is 1.0.56 but the problems started one or two versions earlier. I guess there were UI changes back then. My device is Acer Iconia B1-A71 (Android 4.1.2).

The app crashes almost every time I open a question, sometimes when starting to scroll down contents and if it is still ok, refreshing a question is too much for it. Big problem is that I have no idea what happens: the app just closes but it does not offer any way of reporting it!

To clarify, Android's own Report problem dialog does not appear after crash and the app is not even debuggable so I can't have a closer look at it using Android Studio either.

Crashes are not specific to any single site in this network. For example this question did crash earlier every time on load but now the crashes are happening only on refresh. Here is an external link to a video capture of the crash

I managed to get some logcat information (level: debug, searched for "marvin"):

02-07 14:07:46.841     861-1100/? I/ActivityManager﹕ START {cmp=com.stackexchange.marvin/.ui.TabletBaseActivity (has extras) u=0} from pid 13744
02-07 14:07:47.184  13744-13744/? D/ActivityThread﹕ ACT-NEW_INTENT handled : 0 / NewIntentData{intents=[Intent { cmp=com.stackexchange.marvin/.ui.TabletBaseActivity (has extras) }] token=android.os.BinderProxy@41672e68}
02-07 14:07:48.518  13744-13744/? I/webkit/webview_proxy﹕ WebView() constructor=com.stackexchange.marvin.ui.common.PrettyWebView@41676c30
02-07 14:07:48.965  13744-13744/? I/webkit/webview_proxy﹕ Webview.loadDataWithBaseURL() this=com.stackexchange.marvin.ui.common.PrettyWebView@41676c30 baseUrl: http://empty
02-07 14:07:49.122  13744-13744/? I/webkit/webview_proxy﹕ WebView() constructor=com.stackexchange.marvin.ui.common.PrettyWebView@4157d040
02-07 14:07:49.243  13744-13744/? I/webkit/webview_proxy﹕ Webview.loadDataWithBaseURL() this=com.stackexchange.marvin.ui.common.PrettyWebView@4157d040 baseUrl: http://empty
02-07 14:07:52.127  13744-13744/? I/webkit/webview_proxy﹕ WebView() constructor=com.stackexchange.marvin.ui.common.PrettyWebView@418bcf48
02-07 14:07:52.193  13744-13744/? I/webkit/webview_proxy﹕ Webview.loadDataWithBaseURL() this=com.stackexchange.marvin.ui.common.PrettyWebView@418bcf48 baseUrl: http://empty
02-07 14:07:53.184  13744-13744/? I/webkit/webview_proxy﹕ WebView() constructor=com.stackexchange.marvin.ui.common.PrettyWebView@419f2a78
02-07 14:07:53.265  13744-13744/? I/webkit/webview_proxy﹕ Webview.loadDataWithBaseURL() this=com.stackexchange.marvin.ui.common.PrettyWebView@419f2a78 baseUrl: http://empty
02-07 14:07:53.289  13744-13806/? D/Posix﹕ [Posix_connect Debug]Process com.stackexchange.marvin :443
02-07 14:07:53.398  13744-13744/? I/webkit/webview_proxy﹕ WebView() constructor=com.stackexchange.marvin.ui.common.PrettyWebView@417230a0
02-07 14:07:53.437  13744-13744/? I/webkit/webview_proxy﹕ Webview.loadDataWithBaseURL() this=com.stackexchange.marvin.ui.common.PrettyWebView@417230a0 baseUrl: http://empty
02-07 14:07:53.562  13744-13801/? D/Posix﹕ [Posix_connect Debug]Process com.stackexchange.marvin :443
02-07 14:07:53.616  13744-13744/? I/webkit/webview_proxy﹕ WebView() constructor=com.stackexchange.marvin.ui.common.PrettyWebView@419a06a8
02-07 14:07:53.664  13744-13744/? I/webkit/webview_proxy﹕ Webview.loadDataWithBaseURL() this=com.stackexchange.marvin.ui.common.PrettyWebView@419a06a8 baseUrl: http://empty
02-07 14:07:53.844  13744-13744/? A/libc﹕ Fatal signal 11 (SIGSEGV) at 0x00000008 (code=1), thread 13744 (exchange.marvin)
02-07 14:07:53.864  13744-13802/? D/Posix﹕ [Posix_connect Debug]Process com.stackexchange.marvin :443
02-07 14:07:53.899  13843-13843/? I/DEBUG﹕ pid: 13744, tid: 13744, name: exchange.marvin  >>> com.stackexchange.marvin <<<
02-07 14:07:54.400     861-1940/? I/WindowState﹕ WIN DEATH: Window{41f2d230 com.stackexchange.marvin/com.stackexchange.marvin.ui.TabletBaseActivity paused=false}
02-07 14:07:54.401     861-1100/? I/ActivityManager﹕ Process com.stackexchange.marvin (pid 13744) has died.
02-07 14:07:54.402     861-1100/? W/ActivityManager﹕ Force removing ActivityRecord{41cf9678 com.stackexchange.marvin/.ui.TabletBaseActivity}: app died, no saved state

I can't get more useful logs out of this. Search using com.stackexchange.marvin or StackExchangeAndroid did not help nor trying to use some process ids.

However, this behavior in addition of Fatal signal 11 (SIGSEGV)... makes me suspect something related to memory or Hardware Acceleration with this Android API level 16.

  • I have no such crash on 4.1.1 (also none on other devices with 4.4.4 and 5.0.2). Just one thing in 4.1.1, when I'm in the About view, I can't go back with the Left Arrow left the the About caption. This works ok on 4.4.4 and 5.0.2. – ott-- Feb 7 '15 at 16:45
  • Could you mention your device model on the question body? I never face this problem on Nexus 4 (phone). It might be tablet-only issue, since the UI is specialized. – Meta Andrew T. Feb 8 '15 at 8:30
  • 1
    I have lots of crashes when viewing questions too in Lenovo P770 phone, Android 4.1.1, app version 1.0.56. So this issue should not be tablet-specific. Opening questions most likely results in a crash. When a question can be viewed successfully, it can be re-viewed again safely even though opening other questions may still result in crashes. Interestingly, clearing app cache & app data will not change this behaviour, crashes still happen and successfully viewed questions (before the reset) can still be viewed safely after the reset. – aff Feb 8 '15 at 16:05
  • 1
    Version 1.0.57 is pretty much unusable too. Same behavior. – Kuitsi Feb 17 '15 at 9:40
  • Have you tried clearing the cache? Clearing the data? The steps here may be helpful. – ale Mar 3 '15 at 0:58
  • Thanks for the super helpful report -- I'm working on trying to reproduce this on a similar device right now. – Kasra Rahjerdi Mar 3 '15 at 18:29
  • @AlE. Tried clearing cache, reinstalling app, moving it to sdcard and none worked. This is the first app I have seen crashing without showing the "send a crash report" dialog. – Kuitsi Mar 3 '15 at 19:59
  • Are you on the beta channel by chance? I'm pushing a update out that I think should fix this to it. If you're not, mind signing up here: plus.google.com/communities/116770445014869505908 – Kasra Rahjerdi Mar 4 '15 at 22:04
  • @KasraRahjerdi 1.0.58 does not crash but for example beatcracker's answer is totally blank in this question. However, clicking at assumed position of his stacktrace will open it in popup. – Kuitsi Mar 5 '15 at 17:01
  • 1
    @KasraRahjerdi what was the fix? I'm currently developing my own application and i have the exact same problem on 4.1.2. – user285853 Mar 5 '15 at 20:22
  • @KasraRahjerdi I'd like to know too how you fixed this. I would even accept it as an answer. :) And those blank questions/answers I mentioned before seems to be an old issue: meta.stackexchange.com/q/231354/214673 – Kuitsi Mar 15 '15 at 20:01
  • @KasraRahjerdi Can you please answer? :) – user285853 Mar 17 '15 at 19:30
  • @Karl sorry, will in a bit. This isn't really fixed yet since not showing posts is only a bandaid over the crashes, but I'll post explaining what I did to stop the crashes. – Kasra Rahjerdi Mar 17 '15 at 19:31
7

Okay. Sorry for the long delay, but I didn't want to post an answer until I had fixed the actual issue behind this. For now I'll keep the scope to this specific crash, I'll explain the other issues on the other questions that are related to this.

Here's what was happening:

Our application uses GPU acceleration to render views faster. Straight from the horse's mouth, here's what hardware accelerated views do:

Indicates that the view has a hardware layer. A hardware layer is backed by a hardware specific texture (generally Frame Buffer Objects or FBO on OpenGL hardware) and causes the view to be rendered using Android's hardware rendering pipeline

What was happening when the app was quitting without any sort of error message was that the texture the view was generating was simply too big to fit in the buffer. So, to stop this specific outcome I did the dumbest band-aid possible: We disabled hardware acceleration on posts when a device was running a version of Android <5.0, because this looks to be a bug that only occurs in the WebKit backed WebView, not the new fancy Chromium backed WebView in Lollipop. Boom. Your issue went away, but the fact that it was no longer crashing caused an even uglier bug to be shown to more people. Read my answer on that post for more information.

  • I'm sorry but this is not completely fixed yet. Granted, this bandaid did stop crashes but the other fix for blank questions/answers brought some crashes back. Overall stability did improve a lot though. Still getting errors like these A/libc﹕ Fatal signal 11 (SIGSEGV) at 0x00000008 (code=1), thread 4028 (exchange.marvin) – Kuitsi Mar 20 '15 at 15:38
  • @Kuitsi could you give me anything else that's in that log? Is there anything in the log tagged com.stackexchange.marvin ? – Kasra Rahjerdi Mar 20 '15 at 19:01
  • @Kasra I was following this question and the moment you posted this answer I observed that the number of fatal crashes went down. I didn't use the app much but now that I tried to, I experience fatal crashes that I consider often enough to report it. I use app version 1.0.68. The simptons are similar with this question: random crash, no crash reporting, fatal signal 11. I currently do not consider creating new question because of the similarity of the problem with this one. I will happily provide CatLogs if you need one. Just tell me where to send it. – aff Jul 13 '15 at 11:54
  • @aff sending logs to androidapp@stackoverflow.com would be lovely. Typically fatal signal crashes are related to out of memory issues with the WebViews, any more logs to help figure it out would be great. – Kasra Rahjerdi Jul 13 '15 at 17:20
  • @Kasra Done. I hope something useful can be found. – aff Jul 13 '15 at 22:33
4

I have this issue too. The app is completely unusable on my device. It crashes constantly to desktop when loading questions. Profile and feed are working fine, until I tap on the question or notification in the feed. It results in the hard crash (no crash pop-up) almost every time. While I understand that it's probably due to the MTK buggy OpenGL driver (libGLESv2_mtk.so), I've never seen this in other apps.

  • App version: 1.0.57
  • Device: Jiayu G3
  • Android version: 4.1.2, rooted
  • Kernel version: 3.4.0

Full logcat log is on pastebin. Here is relevant part:

I/WindowManager(  371): Gaining focus: Window{43888250 com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity paused=false}
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity] connect: api=1
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity] setSynchronousMode: enabled=1
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity] setSynchronousMode: enabled=1
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity] createGraphicBuffer before(NULL) after(0x432db1d8, handle=0x43515a10, w=720, h=1280, f=5)
V/ActivityManager(  371): com.stackexchange.marvin/.ui.BaseActivity: task=TaskRecord{4412a298 #356 A com.stackexchange.marvin U 0}
V/ActivityManager(  371): com.stackexchange.marvin/.ui.LoadDataActivity: task=TaskRecord{4412a298 #356 A com.stackexchange.marvin U 0}
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity] createGraphicBuffer before(NULL) after(0x432a1900, handle=0x43514a60, w=720, h=1280, f=5)
I/ActivityManager(  371): [AppLaunch] Displayed Displayed com.stackexchange.marvin/.ui.BaseActivity: +1s585ms
D/ActivityManager(  371): AP_PROF:AppLaunch_LaunchTime:com.stackexchange.marvin/.ui.BaseActivity:1585:376834864
D/Posix   (26963): [Posix_connect Debug]Process com.stackexchange.marvin :443
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity] createGraphicBuffer before(NULL) after(0x432daae8, handle=0x432dc1d8, w=720, h=1280, f=5)
D/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.LoadDataActivity] cancelBuffer: slot=2
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.LoadDataActivity] disconnect: api=1
I/SurfaceTexture(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.LoadDataActivity] [virtual void android::SurfaceTexture::onBuffersReleased()] mCurrentTexture:1, mCurrentBuf:0x432ce000
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.LoadDataActivity] getReleasedBuffers: returning mask 0xffffffff
D/Posix   (26963): [Posix_connect Debug]Process com.stackexchange.marvin :443
V/ActivityManager(  371): Stopping ActivityRecord{43354ed0 com.stackexchange.marvin/.ui.LoadDataActivity}: nowVisible=true waitingVisible=true finishing=true
V/ActivityManager(  371): Before stopping, can hide: ActivityRecord{43354ed0 com.stackexchange.marvin/.ui.LoadDataActivity}
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.LoadDataActivity] consumerDisconnect
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.LoadDataActivity] ~BufferQueue
V/ActivityManager(  371): com.stackexchange.marvin/.ui.BaseActivity: task=TaskRecord{4412a298 #356 A com.stackexchange.marvin U 0}
V/ActivityManager(  371): com.stackexchange.marvin/.ui.LoadDataActivity: task=TaskRecord{4412a298 #356 A com.stackexchange.marvin U 0}
V/ActivityManager(  371): Activity idle: Token{43010830 ActivityRecord{43394c28 com.stackexchange.marvin/.ui.BaseActivity}}
V/ActivityManager(  371): Stopping ActivityRecord{43354ed0 com.stackexchange.marvin/.ui.LoadDataActivity}: nowVisible=true waitingVisible=false finishing=true
V/ActivityManager(  371): Ready to stop: ActivityRecord{43354ed0 com.stackexchange.marvin/.ui.LoadDataActivity}
I/Current (26963): Activity Stopped: com.stackexchange.marvin.ui.LoadDataActivity
V/ActivityManager(  371): com.stackexchange.marvin/.ui.BaseActivity: task=TaskRecord{4412a298 #356 A com.stackexchange.marvin U 0}
I/ActivityManager(  371): START {cmp=com.stackexchange.marvin/.ui.BaseActivity (has extras) u=0} from pid 26963
V/ActivityManager(  371): com.stackexchange.marvin/.ui.BaseActivity: task=TaskRecord{4412a298 #356 A com.stackexchange.marvin U 0}
D/ActivityThread(26963): ACT-NEW_INTENT handled : 0 / NewIntentData{intents=[Intent { cmp=com.stackexchange.marvin/.ui.BaseActivity (has extras) }] token=android.os.BinderProxy@42cb5af8}
I/webkit/webview_proxy(26963): WebView() constructor=com.stackexchange.marvin.ui.common.PrettyWebView@42cd6578
I/webkit/webview_proxy(26963): Webview.loadDataWithBaseURL() this=com.stackexchange.marvin.ui.common.PrettyWebView@42cd6578 baseUrl: http://empty
D/Posix   (26963): [Posix_connect Debug]Process com.stackexchange.marvin :443
I/webkit/webview_proxy(26963): WebView() constructor=com.stackexchange.marvin.ui.common.PrettyWebView@42d59808
I/webkit/webview_proxy(26963): Webview.loadDataWithBaseURL() this=com.stackexchange.marvin.ui.common.PrettyWebView@42d59808 baseUrl: http://empty
V/ActivityManager(  371): com.stackexchange.marvin/.ui.BaseActivity: task=TaskRecord{4412a298 #356 A com.stackexchange.marvin U 0}
D/Posix   (26963): [Posix_connect Debug]Process com.stackexchange.marvin :443
I/DEBUG   (27044): handle_request(15)
I/DEBUG   (27044): BOOM: pid=26963 uid=10131 gid=10131 tid=26963
I/DEBUG   (27044): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
I/DEBUG   (27044): Build fingerprint: 'JIAYU/H958/H958:4.1.2/JZO54K/1358345878:user/test-keys'
I/DEBUG   (27044): pid: 26963, tid: 26963, name: exchange.marvin  >>> com.stackexchange.marvin <<<
I/DEBUG   (27044): signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 00000008
I/DEBUG   (27044):     r0 00000008  r1 54479704  r2 00000010  r3 00000004
I/DEBUG   (27044):     r4 5233c408  r5 5233d498  r6 00000001  r7 00000004
I/DEBUG   (27044):     r8 000010d0  r9 00000001  sl 00000008  fp 00001164
I/DEBUG   (27044):     ip 00000000  sp bebaeb38  lr 53f3cf8c  pc 53f651e0  cpsr 80000010
I/DEBUG   (27044):
I/DEBUG   (27044): backtrace:
I/DEBUG   (27044):     #00  pc 000331e0  /system/vendor/lib/egl/libGLESv2_mtk.so
I/DEBUG   (27044):     #01  pc 0000af88  /system/vendor/lib/egl/libGLESv2_mtk.so
I/DEBUG   (27044):
I/DEBUG   (27044): stack:
I/DEBUG   (27044):          bebaeaf8  00000001
I/DEBUG   (27044):          bebaeafc  bebaeb4c  [stack]
I/DEBUG   (27044):          bebaeb00  00000000
I/DEBUG   (27044):          bebaeb04  00000000
I/DEBUG   (27044):          bebaeb08  00000001
I/DEBUG   (27044):          bebaeb0c  00000000
I/DEBUG   (27044):          bebaeb10  5233c408
I/DEBUG   (27044):          bebaeb14  5233cf58
I/DEBUG   (27044):          bebaeb18  00000004
I/DEBUG   (27044):          bebaeb1c  5233c408
I/DEBUG   (27044):          bebaeb20  5233d490
I/DEBUG   (27044):          bebaeb24  00000000
I/DEBUG   (27044):          bebaeb28  00000004
I/DEBUG   (27044):          bebaeb2c  000010d0
I/DEBUG   (27044):          bebaeb30  df0027ad
I/DEBUG   (27044):          bebaeb34  00000000
I/DEBUG   (27044):     #00  bebaeb38  5233c408
I/DEBUG   (27044):          ........  ........
I/DEBUG   (27044):     #01  bebaeb38  5233c408
I/DEBUG   (27044):          bebaeb3c  53f3cf8c  /system/vendor/lib/egl/libGLESv2_mtk.so
I/DEBUG   (27044):          bebaeb40  00000001
I/DEBUG   (27044):          bebaeb44  5233c408
I/DEBUG   (27044):          bebaeb48  00000004
I/DEBUG   (27044):          bebaeb4c  00000004
I/DEBUG   (27044):          bebaeb50  00000000
I/DEBUG   (27044):          bebaeb54  00000005
I/DEBUG   (27044):          bebaeb58  00000004
I/DEBUG   (27044):          bebaeb5c  53f3e168  /system/vendor/lib/egl/libGLESv2_mtk.so
I/DEBUG   (27044):          bebaeb60  5233c408
I/DEBUG   (27044):          bebaeb64  00000005
I/DEBUG   (27044):          bebaeb68  5233c408
I/DEBUG   (27044):          bebaeb6c  00001124
I/DEBUG   (27044):          bebaeb70  00000004
I/DEBUG   (27044):          bebaeb74  00000005
I/DEBUG   (27044):
I/DEBUG   (27044): memory near r1:
I/DEBUG   (27044):     544796e4 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     544796f4 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     54479704 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     54479714 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     54479724 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):
I/DEBUG   (27044): memory near r4:
I/DEBUG   (27044):     5233c3e8 00000000 00000000 00000000 00000000  ................
I/DEBUG   (27044):     5233c3f8 00000000 00000000 00000000 0000121b  ................
I/DEBUG   (27044):     5233c408 00000018 0000e7fc 00001000 00001100  ................
I/DEBUG   (27044):     5233c418 00001100 00000012 00000319 000002ac  ................
I/DEBUG   (27044):     5233c428 00000050 000002ac 00000050 00000004  P.......P.......
I/DEBUG   (27044):
I/DEBUG   (27044): memory near r5:
I/DEBUG   (27044):     5233d478 00000000 00000000 00000000 00000000  ................
I/DEBUG   (27044):     5233d488 00000000 00000000 5233d06c 5233d194  ........l.3R..3R
I/DEBUG   (27044):     5233d498 5233d1c4 00000000 00000000 00000000  ..3R............
I/DEBUG   (27044):     5233d4a8 00000000 00000000 00000000 00000000  ................
I/DEBUG   (27044):     5233d4b8 00000000 00000000 00000000 00000000  ................
I/DEBUG   (27044):
I/DEBUG   (27044): memory near r8:
I/DEBUG   (27044):     000010b0 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     000010c0 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     000010d0 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     000010e0 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     000010f0 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):
I/DEBUG   (27044): memory near fp:
I/DEBUG   (27044):     00001144 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     00001154 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     00001164 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     00001174 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):     00001184 ffffffff ffffffff ffffffff ffffffff  ................
I/DEBUG   (27044):
I/DEBUG   (27044): memory near sp:
I/DEBUG   (27044):     bebaeb18 00000004 5233c408 5233d490 00000000  ......3R..3R....
I/DEBUG   (27044):     bebaeb28 00000004 000010d0 df0027ad 00000000  .........'......
I/DEBUG   (27044):     bebaeb38 5233c408 53f3cf8c 00000001 5233c408  ..3R...S......3R
I/DEBUG   (27044):     bebaeb48 00000004 00000004 00000000 00000005  ................
I/DEBUG   (27044):     bebaeb58 00000004 53f3e168 5233c408 00000005  ....h..S..3R....
I/DEBUG   (27044):
I/DEBUG   (27044): code around pc:
I/DEBUG   (27044):     53f651c0 e28cc001 e4814004 e15c0003 1afffffa  .....@....\.....
I/DEBUG   (27044):     53f651d0 e8bd8010 e92d4010 e3a0c000 ea000006  .....@-.........
I/DEBUG   (27044):     53f651e0 e5904000 e28cc001 e5814000 e5904004  .@.......@...@..
I/DEBUG   (27044):     53f651f0 e0800002 e5814004 e2811008 e15c0003  .....@........\.
I/DEBUG   (27044):     53f65200 1afffff6 e8bd8010 e92d4010 e3a0c000  .........@-.....
I/DEBUG   (27044):
I/DEBUG   (27044): code around lr:
I/DEBUG   (27044):     53f3cf6c e3a03001 ea000004 e593c024 e5930018  .0......$.......
I/DEBUG   (27044):     53f3cf7c e593101c e5932014 e1a03007 e12fff3c  ..... ...0..<./.
I/DEBUG   (27044):     53f3cf8c e2866001 e7943008 e1560003 3affffe6  .`...0....V....:
I/DEBUG   (27044):     53f3cf9c e2840d45 e1a0100a e280001c e3a02001  E............ ..
I/DEBUG   (27044):     53f3cfac e8bd45f8 eaffe3d4 e92d4ff0 e24dd01c  .E.......O-...M.
V/ActivityManager(  371): com.stackexchange.marvin/.ui.BaseActivity: task=TaskRecord{4412a298 #356 A com.stackexchange.marvin U 0}
D/AEE/AED (27044): Skip for Exp level'0'
I/WindowState(  371): WIN DEATH: Window{43888250 com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity paused=false}
I/ActivityManager(  371): Process com.stackexchange.marvin (pid 26963) has died.
V/ActivityManager(  371): Dying app: ProcessRecord{43328370 26963:com.stackexchange.marvin/u0a131},pid: 26963, thread: android.os.BinderProxy@43a70420
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity] consumerDisconnect
V/ActivityManager(  371): Removing app ProcessRecord{43328370 0:com.stackexchange.marvin/u0a131} from list [ActivityRecord{42f5fa40 com.android.phone/.InCallScreen}, ActivityRecord{43dd9618 com.teslacoilsw.launcher/com.android.launcher2.Launcher}, ActivityRecord{43394c28 com.stackexchange.marvin/.ui.BaseActivity}] with 3 entries
V/ActivityManager(  371): Record #2 ActivityRecord{43394c28 com.stackexchange.marvin/.ui.BaseActivity}: app=ProcessRecord{43328370 0:com.stackexchange.marvin/u0a131}
V/ActivityManager(  371): Removing app ProcessRecord{43328370 0:com.stackexchange.marvin/u0a131} from list [] with 0 entries
V/ActivityManager(  371): Removing app ProcessRecord{43328370 0:com.stackexchange.marvin/u0a131} from list [] with 0 entries
V/ActivityManager(  371): Removing app ProcessRecord{43328370 0:com.stackexchange.marvin/u0a131} from list [] with 0 entries
V/ActivityManager(  371): Removing app ProcessRecord{43328370 0:com.stackexchange.marvin/u0a131} from list [] with 0 entries
W/ActivityManager(  371): Force removing ActivityRecord{43394c28 com.stackexchange.marvin/.ui.BaseActivity}: app died, no saved state
V/WindowManager(  371): Changing focus from Window{43888250 com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity paused=false} to null
I/WindowManager(  371): Losing focus: Window{43888250 com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity paused=false}
I/BufferQueue(   99): [com.stackexchange.marvin/com.stackexchange.marvin.ui.BaseActivity] ~BufferQueue
2

I also have had this exact problem for over an year, but only thought of searching about it now. I am not a power user like the others who posted in this question; my phone does not have root access; I don't know about taking logs or anything. But let me describe exactly what happens:

There are essentialy three different situations in which the app force closes: when scrolling down a question; when refreshing a question; and when loading a question. The latter is the one that happens more often and bothers me most. (I don't remember a single crash when scrolling up - if it ever happens, I will edit here).

Whenever I say "crash" or "force close", I mean the same thing: the app closes suddenly, with no warning or error message, and shows me the phone's desktop)


Scrolling down a question

In the fortunate cases in which the question loaded properly, sometimes it will crash when I scroll it down. I've noticed that the faster I scroll, the higher are the odds that it will crash. Especially if I'm reading a math question with a lot of MathJax symbols.


Refreshing a question

I don't have many details for this one. Sometimes the question loaded well, but when I refresh it, it crashes. I think this happens more often if the question lagged a lot when loading, but take that as a guess - I don't refresh questions too often to have a big statistical confidence/reliability.


Loading a question

This is the one that bothers me most, and the things I'll mention below are not just things that happened once or twice. You can take this information with high statistical confidence, since I'm not afraid to say that I've seen a question crash at least five hundred times now, probably one thousand.

In short, there is usually a lot of lag when loading a question, and many times the app crashes during the loading. I guarantee this is not related to the condition of the internet connection in any way, because I've been using this app in many different locations and internet conditions and never noticed a difference.

When I click to open a question, whether using the 4x1 desktop-widget or opening the app first and then clicking on the question, one of the following happens:

  1. The question opens normally (happens like 20% of the times).

  2. The blue "loading question" screen shows up, and then when the questions starts loading, it immediately crashes (see images below, the crash happens right after the second image shows). By the way, that little white circle at the left of "Loading Stack Exchange sites..." is always very laggy. (this is the most usual way of crashing)

enter image description here

  1. Instead of the blue "loading question" screen, the screen gets all black and the phone is stuck there, not responding to almost anything (I am surprised that it responded to the screenshot command). In these cases I have to repeatedly press the middle button, until after a while, it goes back to the desktop. (this one is rare, happens like 1% of the times)

    enter image description here

  2. The question attempts to start loading, title and comments appear for a fraction of second, but then the app force closes back to desktop. It was hard to get the correct timing for those screenshots, since they stay on screen for just a fraction of second (I had to try many times). This is exactly the type of crash shown by @Kuitsi in this video he linked on his answer. (this is the second most common way of crashing)

enter image description here

  1. In very few cases, the app lags just like explained on 4, but instead of force closing, to my surprise it completes loading! These cases are very rare (percentually), but since I've been experiencing this for over an year, I was able to observe that, in those cases, if I scroll down the question in a fast swipe, it will almost always force close.

  2. When attempting to open math questions with a lot of embedded MathJax (big equations and such), and when it doesn't immediately crash, I've noticed that the MathJax symbols do not load in the same time as the normal text. First, MathJax code shows up itself, along the normal text, and only after a little bit, the code will be replaced with the symbols. The problem is, if the app didn't crash yet, most of the time it will crash right at this moment, when the MathJax code is being replaced with the symbols. Then, in the few times that those questions with a lot of MathJax open correctly, they have a higher chance of crashing when scrolling down than other questions.


About the device

I have a Motorola Razr I (as known as XT890). Android version is 4.1.2. Stack Exchange app version is 1.0.83. A friend of mine also uses the Stack Exchange app on a different device, and he never experienced this force closing, not a single time. It is unfortunate that this depends on the device...

By the way, I think the tag should be removed, since it's still happening for me and most likely for more people.

  • is this case still happening to you? I did not experience this case anymore since I switch to a new phone (with a newer OS: Android M). – aff Dec 22 '16 at 8:13
  • 1
    @aff Not anymore because two months ago I boight a new smartphone, more powerful. I am guessing the issue was related to a lot of too much rendering on the screen for the phone to handle quickly (since the problem was more evident when MathJax was involved). But I am sure the problem would still exist if I didn't change my phone... – Pedro A Dec 22 '16 at 11:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .