3

Auto login is not working in Safari browser(Version 8.0.3 (10600.3.18)) on OS X (Yosemite 10.10.2)

ie., it doesn't detect and show 'Welcome back, < user >. You've been logged in. Click here to refresh the page.'

JS and Cookies are enabled. There are no errors in the console as well.

Situation: I am logged in on meta.stackexchange.com, but it doesn't show that I am logged in when I visit stackoverflow.com & other stack exchange sites

9
  • Sure you're not in Private Mode? Feb 14, 2015 at 20:25
  • @ShadowWizard Nope, positive. Not on Private Mode. Feb 14, 2015 at 20:27
  • What OpenID provider are you using? Feb 14, 2015 at 20:30
  • Google OpenID Login Feb 14, 2015 at 20:32
  • And when you try to access gmail, you get no problems? Feb 14, 2015 at 20:32
  • No problem at all. Its logged in on gmail. Feb 14, 2015 at 20:33
  • Hmm.... so no idea sorry. Guess only a dev with access to the internal logs can shed more light. Feb 14, 2015 at 20:36
  • Cool, shall wait. Thanks. Feb 14, 2015 at 20:39
  • 1
    There are a LOT of weirdness in how cookies work in Safari when you navigate across our 2nd-level domains (from SO to SF, say.) There are some improvements in the works that will solve some, but not all of em.
    – Jaydles
    Feb 14, 2015 at 21:53

1 Answer 1

0

My impression is that's caused by the way stackauth.com authentication was implemented, which breaks with new anti-tracking security settings of the browsers, especially Safari 9 on Mac OS X.

If you enable: allow cookies from all domains, it seems to be working.

See my own ticket: Why do Stack Exchange sites seem to always forget my login?

Not the answer you're looking for? Browse other questions tagged .