43

We used to be able to use symbols in search, but that now appears to be broken.

I'd expect a search for [python] += list to return a result, but instead the search engine appears to put quotes around the whole request; the search box shows the search has been replaced with "[python] += list" and the specific result I was looking for doesn't appear among the returned questions.

Using quotes around the symbols do not seem to help here; [python] "+=" list returns an empty result.

5
  • 2
    Not meant as a solution but as a temporary work-around use SEDE although not useful if you're looking for recent posts or when you have a major tag (python just happens to work...)
    – rene
    Commented Mar 9, 2015 at 10:31
  • 1
    You have only hit the tip of an iceberg. This behavior is far more expansive than anyone realizes.
    – Laurel
    Commented Jun 7, 2016 at 2:33
  • 4
    Note to future self: if this is ever fixed, remember to add instructions back to the help center: Search for special characters isn't working as advertised
    – Shog9
    Commented May 30, 2018 at 19:14
  • Finally the service itself was broken in April 2022. Commented Jan 9, 2023 at 15:49
  • 1
    @This_is_NOT_a_forum this post is has nothing to do with symbolhound, which was an external service. The StackExchange search here used to support symbol searches, at least between 2013 and 2015. Commented Jan 9, 2023 at 21:15

0

You must log in to answer this question.

Browse other questions tagged .